Bug 33393 - JRE (IBM1.1.8-5, IBM1.3 ,SUN1.3) hangs on running SAP PlatinGUI
JRE (IBM1.1.8-5, IBM1.3 ,SUN1.3) hangs on running SAP PlatinGUI
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brock Organ
ftp://ftp.sap.com/pub/sapgui/java/46D...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-27 10:16 EST by passon
Modified: 2016-11-24 10:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-21 21:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
javacore11086.txt (7.00 KB, text/plain)
2001-03-29 08:35 EST, Karsten Hopp
no flags Details

  None (edit)
Description passon 2001-03-27 10:16:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [de] (X11; U; Linux 2.4.2-0.1.36 i686)


I opened this in bugzilla, since it is reproduceable with various JREs.

Running SAP PlatinGUI on Wolverine leads to:
1. IBM1.1.8JRE neverending SIGSEGV (Segmentation fault)
2. IBM1.3JRE neverending SIGSEGV (Segmentation fault)
3. SUM1.3JRE infinite loop of nanosleeps

Making straces (s. additional information) finishes only in jre1.1.8ibm
with SIGSEGV, 1.3 (IBM or SUN) loops in SIGSEGV and nanosleep resp.


Reproducible: Always
Steps to Reproduce:
1.install PlatinGUI with rpm -ivh PlatinGUI-LinuxIntel-46Dr20.rpm
2.install IBM118jre from www.ibm.com/java
3.cd /usr/bin; ln -s ../jre118/bin/jre
4. strace guilogon 

(all can be done as root)
	

Actual Results:  nothing :)

Expected Results:  GUI should come up with dialog window

also tried with newest kernel and glibc:
kernel-2.4.2-0.1.36,glibc-2.2.2-9
Comment 1 Arjan van de Ven 2001-03-27 10:21:23 EST
sounds like a glibc issue
Comment 2 passon 2001-03-27 10:25:10 EST
These straces were snipped from my orignal bug-message by bugzilla :(

----------start of strace from guilogon with ibm1.1.8jre------------
...
sendto(7, "\17\316&\34\0\0\0\0\0\0\0\2\0\1\206\244\0\0\0\2\0\0\0\3"..., 84, 0,
{sin_family=AF_INET, sin_port=htons(946), sin_addr=inet_addr("10.18.64.43")}},
16) = 84
poll([{fd=7, events=POLLIN, revents=POLLIN}], 1, 5000) = 1
recvfrom(7, "\17\316&\34\0\0\0\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 8800,
0, {sin_family=AF_INET, sin_port=htons(946),
sin_addr=inet_addr("10.18.64.43")}}, [16]) = 124
close(7)                                = 0
open("/etc/mtab", O_RDONLY)             = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=445, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40018000
read(3, "/dev/hda8 / ext2 rw 0 0\nnone /pr"..., 4096) = 445
close(3)                                = 0
munmap(0x40018000, 4096)                = 0
open("/proc/cpuinfo", O_RDONLY)         = 3
fstat64(3, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40018000
read(3, "processor\t: 0\nvendor_id\t: Genuin"..., 4096) = 370
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0x40018000, 4096)                = 0
modify_ldt(0x11, 0xbffff3e4, 0x10)      = 0
getrlimit(0x3, 0xbffff3c0)              = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++
--------------end of strace from guilogon with ibm1.1.8jre--------




----------start of strace from guilogon with ibm1.3jre------------
...
rt_sigprocmask(SIG_SETMASK, [USR1 RT_0], NULL, 8) = 0
lseek(3, 1073129, SEEK_SET)             = 1073129
lseek(3, 0, SEEK_CUR)                   = 1073129
rt_sigprocmask(SIG_UNBLOCK, [USR1], [USR1 RT_0], 8) = 0
read(3, "\215R[O\23a\20=_[Y\273]\240\240x\251\n\242\200\245\27*"..., 683) = 683
rt_sigprocmask(SIG_SETMASK, [USR1 RT_0], NULL, 8) = 0
getrlimit(0x3, 0xbffff488)              = 0
brk(0x80cf000)                          = 0x80cf000
pipe([8, 9])                            = 0
clone(child_stack=0x80ce030, flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND)
= 1564
write(9, "\30\0\4\1\5\0\0\0\334\311\5@\200\7\0\0\16g\6@\354\324\5"..., 148) =
148
rt_sigprocmask(SIG_SETMASK, NULL, [USR1 RT_0], 8) = 0
write(9, "\200>\3@\0\0\0\0x\365\377\2770\36/@\260\272\f\10\0\2\0"..., 148) = 148
rt_sigprocmask(SIG_SETMASK, NULL, [USR1 RT_0], 8) = 0
rt_sigsuspend([USR1] <unfinished ...>
--- SIGRT_0 (Real-time signal 0) ---
<... rt_sigsuspend resumed> )           = -1 EINTR (Interrupted system call)
sigreturn()                             = ? (mask now [USR1])
rt_sigaction(SIGFPE, {0x4002b970, ~[USR2], SA_RESTART|SA_SIGINFO|0x4000000},
{SIG_DFL}, 8) = 0
rt_sigaction(SIGSEGV, {0x4002b970, ~[USR2], SA_RESTART|SA_SIGINFO|0x4000000},
{SIG_DFL}, 8) = 0
rt_sigaction(SIGSEGV, {SIG_DFL}, {0x4002b970, ~[KILL USR2 STOP],
SA_RESTART|SA_SIGINFO|0x4000000}, 8) = 0
rt_sigaction(SIGSEGV, {0x4002b970, ~[KILL USR2 STOP],
SA_STACK|SA_RESTART|SA_SIGINFO|0x4000000}, {SIG_DFL}, 8) = 0
rt_sigaction(SIGILL, {0x4002b970, ~[USR2], SA_RESTART|SA_SIGINFO|0x4000000},
{SIG_DFL}, 8) = 0
rt_sigaction(SIGQUIT, {0x4002b970, ~[USR2], SA_RESTART|SA_SIGINFO|0x4000000},
{SIG_DFL}, 8) = 0
rt_sigaction(SIGABRT, {0x4002b970, ~[USR2], SA_RESTART|SA_SIGINFO|0x4000000},
{SIG_DFL}, 8) = 0
rt_sigaction(SIGBUS, {0x4002b970, ~[USR2], SA_RESTART|SA_SIGINFO|0x4000000},
{SIG_DFL}, 8) = 0
rt_sigaction(SIGTRAP, {0x4002b970, ~[USR2], SA_RESTART|SA_SIGINFO|0x4000000},
{SIG_DFL}, 8) = 0
rt_sigaction(SIGXCPU, {0x4002b970, ~[USR2], SA_RESTART|SA_SIGINFO|0x4000000},
{SIG_DFL}, 8) = 0
rt_sigaction(SIGXFSZ, {0x4002b970, ~[USR2], SA_RESTART|SA_SIGINFO|0x4000000},
{SIG_DFL}, 8) = 0
--- SIGSEGV (Segmentation fault) ---
rt_sigprocmask(SIG_BLOCK, NULL, ~[KILL USR2 STOP], 8) = 0
--- SIGSEGV (Segmentation fault) ---
--- SIGSEGV (Segmentation fault) ---
--- SIGSEGV (Segmentation fault) ---
--- SIGSEGV (Segmentation fault) ---
... (continued infinitly)
------------end of strace from guilogon with ibm1.3jre------------




----------start of strace from guilogon with ibm1.3sun------------
...

----------start of strace from guilogon with ibm1.3sun------------
...
read(3, "\312\376\272\276\0\3\0-\0\27\n\0\3\0\20\n\0\4\0\20\7\0"..., 419) = 419
_llseek(3, 2269257, [2269257], SEEK_SET) = 0
read(3, "PK\3\4\n\0\0\0\0\0\247\2212)\247\243\244\223,\4\0\0,\4"..., 76) = 76
_llseek(3, 2269333, [2269333], SEEK_SET) = 0
read(3, "\312\376\272\276\0\3\0-\0:\n\0\f\0\25\n\0\26\0\27\n\0\26"..., 1068) =
1068
rt_sigprocmask(SIG_SETMASK, NULL, [RT_0], 8) = 0
write(10, "\200>\3@\0\0\0\0$\320\377\277\250\303\35@H$\t\10\0\0\0"..., 148) =
148
rt_sigprocmask(SIG_SETMASK, NULL, [RT_0], 8) = 0
rt_sigsuspend([] <unfinished ...>
--- SIGRT_0 (Real-time signal 0) ---
<... rt_sigsuspend resumed> )           = -1 EINTR (Interrupted system call)
sigreturn()                             = ? (mask now [])
sched_getscheduler(0x509)               = 0
sched_getparam(0x509, 0xbfffd024)       = 0
kill(1289, SIGRT_0)                     = 0
kill(1289, SIGRT_0)                     = 0
kill(1289, SIGRT_0)                     = 0
kill(1289, SIGRT_0)                     = 0
kill(1289, SIGRT_0)                     = 0
_llseek(3, 2271006, [2271006], SEEK_SET) = 0
read(3, "PK\3\4\n\0\0\0\0\0\247\2212)\5\370\264\337\363\6\0\0\363"..., 64) = 64
_llseek(3, 2271070, [2271070], SEEK_SET) = 0
read(3, "\312\376\272\276\0\3\0-\0O\n\0\24\0001\7\0002\n\0\2\000"..., 1779) =
1779
_llseek(3, 2272849, [2272849], SEEK_SET) = 0
read(3, "PK\3\4\n\0\0\0\0\0\247\2212)\321\327ZB\367\1\0\0\367\1"..., 69) = 69
_llseek(3, 2272918, [2272918], SEEK_SET) = 0
read(3, "\312\376\272\276\0\3\0-\0\27\n\0\3\0\22\n\0\4\0\22\7\0"..., 503) = 503
_llseek(3, 2273421, [2273421], SEEK_SET) = 0
read(3, "PK\3\4\n\0\0\0\0\0\247\2212)\341\n&q\274\1\0\0\274\1\0"..., 69) = 69
_llseek(3, 2273490, [2273490], SEEK_SET) = 0
read(3, "\312\376\272\276\0\3\0-\0\27\n\0\3\0\20\n\0\4\0\20\7\0"..., 444) = 444
_llseek(3, 2280560, [2280560], SEEK_SET) = 0
read(3, "PK\3\4\n\0\0\0\0\0\252\2212)\242Y\207\364\315\2\0\0\315"..., 75) = 75
_llseek(3, 2280635, [2280635], SEEK_SET) = 0
read(3, "\312\376\272\276\0\3\0-\0&\10\0\22\n\0\t\0\23\n\0\5\0\24"..., 717) =
717
rt_sigprocmask(SIG_SETMASK, NULL, [RT_0], 8) = 0
write(10, "\200>\3@\0\0\0\0\334\321\377\277\250\303\35@\320>\t\10"..., 148) =
148
rt_sigprocmask(SIG_SETMASK, NULL, [RT_0], 8) = 0
rt_sigsuspend([] <unfinished ...>
--- SIGRT_0 (Real-time signal 0) ---
<... rt_sigsuspend resumed> )           = -1 EINTR (Interrupted system call)
sigreturn()                             = ? (mask now [])
sched_yield()                           = 0
sched_yield()                           = 0
sched_yield()                           = 0
sched_yield()                           = 0
sched_yield()                           = 0
sched_yield()                           = 0
sched_yield()                           = 0
sched_yield()                           = 0
sched_yield()                           = 0
sched_yield()                           = 0
nanosleep({0, 1000000}, {3076, 0})      = 0
nanosleep({0, 1000000}, {3076, 0})      = 0
nanosleep({0, 1000000}, {3076, 0})      = 0
nanosleep({0, 1000000}, {3076, 0})      = 0
... (continued infinitely)
Comment 3 passon 2001-03-27 10:27:03 EST
Another thing that was snipped (or is it netscape that snipps here :)

also tried with newest kernel and glibc:
kernel-2.4.2-0.1.36, glibc-2.2.2-9 (i386 + i686),  glibc-common-2.2.2-9
Comment 4 Jakub Jelinek 2001-03-27 10:38:48 EST
Does export LD_ASSUME_KERNEL=2.2.5 help with glibc 2.2.2-9?
Comment 5 passon 2001-03-27 10:54:19 EST
export LD_ASSUME_KERNEL=2.2.5 resulted in 

1. running program with IBM and SUN 1.3 JRE (nice, but why ?-) bug or fearture
;)


2. with IBM118JRE in a SIGSEGV termination (no more infinite loop) with
response:

SIGSEGV received at bfffe08c in /usr/jre118/lib/linux/native_threads/libjava.so.
Processing terminated
Comment 6 Jakub Jelinek 2001-03-27 10:59:43 EST
1. bug, but in JDK, so we have provided a work-around and Sun should come up
with fixed JDK soon. The same bug is in IBM JDK AFAIK.

2. I look at it, but it is quite hard to debug these things when one does not
have sources.
Comment 7 passon 2001-03-27 12:11:45 EST
Thanx, that was really great support!

Hope this will be really fixed before 7.1 is coming out. So SAP customers will 
not have to bother about it, when they try to run the SAP GUI on RedHat 7.1.

Bye,

Chris
Comment 8 passon 2001-03-28 03:01:54 EST
One more remark: This workaround does not work with kernel/glibc from wolverine
release :(
Comment 9 Jakub Jelinek 2001-03-28 03:30:17 EST
Yeah, it has been added after Wolverine was released.
Comment 10 passon 2001-03-28 07:55:16 EST
Another remark: the Oracle DB installer uses also a 1.1.8 JavaVM, resulting in
the same SIGSEGV. 

So the workaround would not help the Oracle users ( :( or :) from the point of
view ;)
Comment 11 Karsten Hopp 2001-03-29 08:35:04 EST
We still have problems installing oracle 8.1.6 on a Red Hat 7.1 with the current 
glibc and LD_ASSUME_KERNEL=2.2.5.
Without LD_ASSUME_KERNEL the jre processes of the Oracle installer take 99.9%CPU
and a strace shows that they are continously segfaulting.
With LD_ASSUME_KERNEL we get a javacore file and the Oracle installer processes
are being killed. I'll attach one of our javacore files.
It must be something with the java environment of the Oracle installer because
the SAP-R/3 Java frontend works quite well with IBM JRE 1.1.8 and
LD_ASSUME_KERNEL.
Comment 12 Karsten Hopp 2001-03-29 08:35:41 EST
Created attachment 14083 [details]
javacore11086.txt
Comment 13 Jakub Jelinek 2001-03-29 08:44:55 EST
Karsten, are you using the whole environment and rpms as specified in
#33568 or just LD_ASSUME_KERNEL?
Comment 14 Karsten Hopp 2001-04-02 13:04:36 EDT
I wasn't aware of the other variables and exported only LD_ASSUME_KERNEL
I'll try again and report my results
Comment 15 Karsten Hopp 2001-04-05 08:30:15 EDT
I don't know how dkl managed to get this working, but I still get this:
bash-2.04$ SIGSEGV received at bfffdbf8 in
/data/karsten/Oracle/stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/lib/linux/native_threads/libjava.so.
Processing terminated

I followed your instructions from #33568, the needed packages are installed and
their versions are ok. The only difference is that the javacore
gets dumped on the screen and not in a file.
Comment 16 Jakub Jelinek 2001-04-05 10:10:23 EDT
Maybe it is locale related.
Karsten, does it happen during Oracle install or afterwards?
Can you find out which exact binary is triggering it, what exact environment
does it have an pack up all files it touches during its run (from strace)?
I remember doing a workaround for java_lang_System_initProperties bugs, perhaps
they have made further bugs in that routine.
Comment 17 Hamish Martin 2001-04-19 01:01:16 EDT
Appears to be related to hotspot stuff. If you alter jre/lib/jvm.cfg to have
-classic at the top (ie above -client) things appear to work correctly.
Comment 18 Ulrich Drepper 2003-04-21 21:39:06 EDT
I'm closing the bug.  This is almost always an issue with the JVM code.  Recent
JVMs got better (well, at least Sun's) in that they don' misuse internal
symbols.  IBM's still has those problems.

Anyway, for RHL9 you in any case need Sun JRE 1.4.1 or up.  Alternatively the
LD_ASSUME_KERNEL hack is available to work around some JVM problems.  For all
problems which cannot be solved by either of these methods you're either out of
luck or you have to contact the JRE producer.

Note You need to log in before you can comment on or make changes to this bug.