Bug 334341 - Software-Updater crashes
Software-Updater crashes
Status: CLOSED DUPLICATE of bug 321251
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-16 10:17 EDT by Tobias Vogel
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-16 14:08:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tobias Vogel 2007-10-16 10:17:37 EDT
Description of problem:

If you try to do a software-update, the updater very shortly brings up the
looking for updates dialog and then crashes.

Version-Release number of selected component (if applicable):

How reproducible:

Try to do an update.
Actual results:

No update possible.

Additional info:


Component: pirut
Summary: TB19ba829d __init__.py:158:pirutCDHandler:NameError: global name
'DBusException' is not defined

Traceback (most recent call last):
  File "/usr/sbin/pup", line 614, in <module>
  File "/usr/sbin/pup", line 610, in main
  File "/usr/sbin/pup", line 449, in run
  File "/usr/sbin/pup", line 267, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 302, in
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 268, in reposSetup
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 526, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 242, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 142, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 199, in
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 769, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 761, in _getRepoXML
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 744, in _loadRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 574, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative =
relative, text = text, copy_local = copy_local, url = url, mediaid =
self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 158, in
    except DBusException, e:
NameError: global name 'DBusException' is not defined

Local variables in innermost frame:
hal: <Interface <ProxyObject wrapping <dbus._dbus.SystemBus (system) at
0x1357bf0> :1.5 /org/freedesktop/Hal/Manager at 0x1373f50> implementing
'org.freedesktop.Hal.Manager' at 0x1373fd0>
name: Fedora 7.92
self: <__main__.PackageUpdater object at 0x108d690>
args: ()
umount: False
mediaid: 1191242166.874799
HalCD: <module 'pirut.HalCD' from
dev: <pirut.HalCD.HALBlockDevice instance at 0x1379680>
discnum: 1
kwargs: {'mediaid': '1191242166.874799', 'name': 'Fedora 7.92', 'url': None,
'text': <yum.yumRepo.YumRepository object at 0x136f410>, 'relative':
'repodata/repomd.xml', 'range': (None, None), 'checkfunc': (<bound method
YumRepository._checkRepoXML of <yum.yumRepo.YumRepository object at 0x136f410>>,
(), {}), 'copy_local': 1, 'discnum': 1, 'local':
found: False
cdudi: /org/freedesktop/Hal/devices/storage_model_DVD_RW_ND_1300A
Comment 1 Jeremy Katz 2007-10-16 14:08:50 EDT

*** This bug has been marked as a duplicate of 321251 ***

Note You need to log in before you can comment on or make changes to this bug.