Bug 334601 - Hal Fails to load USB Storage Devices : Not in Active Session
Hal Fails to load USB Storage Devices : Not in Active Session
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 11:14 EDT by Chris Ward
Modified: 2013-03-05 22:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 11:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ward 2007-10-16 11:14:55 EDT
Description of problem:
Upon plugging in my External USB Hardrive, or USB pendrive I get the following
error dialog.

"Cannot mount volume.

Error org.freedesktop.Hal.PermissionDenied.

Details
Permission Denied: Not in Active Session"

The same error occurs if you try to right-click the device (which does appear)
and click Mount. 

Version-Release number of selected component (if applicable):
hal-0.5.9-8.fc7

How reproducible:
Always

Steps to Reproduce:
1.Plug in External USB Storage Device (pin drive, or HardDisk)
  
Actual results:
Fails to mount.

Expected results:
The device should automount without any error.

Additional info:
I am using bleeding edge fedora 8 test 3. 

Manual mount /dev/sdb1 works.

Write me if more info is needed.
Comment 1 David Zeuthen 2007-10-16 11:24:49 EDT
Questions

 1. Are you logging in via a) startx; b) gdm; or c) kdm. Does it happen
    if you try to log in in a different way?

 2. What desktop are you running? 

 3. Can you reproduce this or does it only happen some of the time?


Comment 2 Chris Ward 2007-10-29 03:40:38 EDT
Okay, update on info.

I'm actually NOT running fedora 8 test 3, sorry. I'm running fedora 7, with all
the updates though. I was confused on which machine I was getting the error :-)

I'm running Gnome 2.18.3, starting from gdm, and it happens all the time. 

For example, I just started up my computer, popped in my usb stick, and the
error occurred. Hal fails, saying something like not in session, as i mentioned
above. 

I'll try it when i log in different ways and let you know.

Tell me what more info you could use and i'll post it to you.
Comment 3 Chris Ward 2007-10-29 04:01:06 EDT
So, after an init 4, 

startx, kdm, and gdm logins did not reproduce the issue. I was able to load up
my desktop, pop in the usb stick and it showed up.

However, the moment I init 5'd, and logged in via gdm again, as I usually do,
when I put in the usb stick, I got the same error.

Comment 4 David Zeuthen 2007-10-29 10:33:21 EDT
Re comment 3 : so please update the bug to reflect it's f7

What is run level 4? It sounds like you have the ConsoleKit service disabled
when this is not working; can you confirm that? Thanks.
Comment 5 Chris Ward 2007-10-30 05:31:50 EDT
Thanks for updating the state to f7. Run level 4 is an admin runlevel, or
basically, it's just the same as 4 - everything except X11. Why i do 4 instead
of 3, beats me...:-) Just habbit. 

It looks like not having ConsoleKit service enabled was the cause. I enabled it,
popped in my usb stick, and it mounted fine. 

Perhaps then, there should be a bug / enhancement made to add more info to the
description of ConsoleKit. And / or a warning dialog when an external drive is
connected and ConsoleKit is not active, warning of the likelyhood that any error
or inability to mount will be caused by ConsoleKit not being enabled.

Currently, when running system-config-services, it says only "The ConsoleKit
maintains a list of sessions". 

Therefore when users are enabling/disabling services, they (like me) have no
idea that there would be a connection between mounting of external drives, etc,
with ConsoleKit.

I can see now the connection at least between ConsoleKit and the error message
about sessions, but i disabled ConsoleKit many weeks ago, and so had forgotten
that message. 

What do you think?
Comment 6 David Zeuthen 2007-10-30 11:43:59 EDT
(In reply to comment #5)
> > Currently, when running system-config-services, it says only "The ConsoleKit
> maintains a list of sessions". 

It shouldn't be possible for users to turn off ConsoleKit.. but that's a more
general problem. Maybe the text should be updated though..

> Therefore when users are enabling/disabling services, they (like me) have no
> idea that there would be a connection between mounting of external drives, etc,
> with ConsoleKit.

I don't think you can expect things to Just Work(tm) if you randomly disable
services you don't know about...

Note You need to log in before you can comment on or make changes to this bug.