Bug 33474 - Floating point exception
Floating point exception
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-27 14:26 EST by Wade Minter
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 02:51:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The bplSMRatio.i file (803.31 KB, text/plain)
2001-03-28 12:48 EST, Wade Minter
no flags Details

  None (edit)
Description Wade Minter 2001-03-27 14:26:36 EST
During a compile of the product here at work, GCC spit out:

gcc -O3 -g -Dprivate= -Dprotected= -Dpublic= -D__VPD__
-DENTERPRISE_2000_4 -D_LIBPL_2000_4_ -DENTERPRISE__APOLLO_MODE -DUNIX
-DLOBYT_HIBYT -DISS_SYSTYPE=\"I386\" -DLINUX__2_2 -DRELEASE -pipe -DI386
-D__NO_STRING_INLINES  -I.
-I../../../arch/i386-intel-linux2.2/OPT/include
-I/rtp/code/PandR/2001.2/arch/i386-intel-linux2.2/OPT/include
-I/usr/X11R6/include -I/rtp/code/TK/tcl/include
-I/rtp/code/TK/tk/include -I/rtp/code/TK/tix/include
-I/rtp/code/TK/blt/include
-I/rtp/code/build/VICTOR/arch/i386-intel-linux2.2/OPT/include -c
bplSMRatio.c -o
../../../arch/i386-intel-linux2.2/OPT/obj/libbpl.a/bplSMRatio.xyzzy.o
bplSMRatio.c: In function `bpliSetSelectedBlocks':
bplSMRatio.c:156: Internal error: Floating point exception.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: ***
[../../../arch/i386-intel-linux2.2/OPT/obj/libbpl.a/bplSMRatio.o] Error
1


More details available as needed.
Comment 1 Jakub Jelinek 2001-03-27 16:00:40 EST
Yes please. Rerun the above command with additional
-save-temps -v
options and attach here bplSMRatio.i it creates.
Thanks.
Comment 2 Wade Minter 2001-03-28 12:48:12 EST
Created attachment 13984 [details]
The bplSMRatio.i file
Comment 3 Wade Minter 2001-03-28 12:48:47 EST
I've attached the file.
Comment 4 Jakub Jelinek 2001-03-29 09:22:18 EST
Thanks, reproduced.
It looks like ifcvt does not handle strict_low_part properly (both in
2.96-RH and gcc-3.1). Debugging...
Comment 5 Jakub Jelinek 2001-03-29 11:54:27 EST
I've fix in my tree and was mailed to gcc-patches as well (but gcc.gnu.org
is dead ATM).
Comment 6 Jakub Jelinek 2001-03-30 02:51:40 EST
FYI the patch is at http://gcc.gnu.org/ml/gcc-patches/2001-03/msg01975.html
Comment 7 Jakub Jelinek 2001-04-09 07:55:50 EDT
Fixed in gcc-2.96-81.

Note You need to log in before you can comment on or make changes to this bug.