Bug 33479 - The "rsh-server" package has a mistake in its "/etc/xinetd.d/rexec" file.
The "rsh-server" package has a mistake in its "/etc/xinetd.d/rexec" file.
Status: CLOSED DUPLICATE of bug 18107
Product: Red Hat Linux
Classification: Retired
Component: rsh (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-27 16:13 EST by Christopher Wolfe
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 16:13:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Wolfe 2001-03-27 16:13:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


The "/etc/xinetd.d/rexec" file that comes with the "rsh-server" package has
a mistake in it.  The line "server = /usr/sbin/in.rlogind" should be
changed to "server = /usr/sbin/in.rexecd".

If this line is not corrected; then you're using the wrong server, and
rexec connections will seem to hang and do nothing.

Affects rsh-server-0.17-2.2.

Reproducible: Always
Steps to Reproduce:
1. Install "rsh-server-0.17-2.2.i386.rpm".
2. Enable the rexec server.
3. Try to rexec into the machine.  Try something simple, like "rexec
<host-name> ls".
	

Actual Results:  As expected, it prompts you for a password.

After entering the password, it just sits there and seems to hang.
(You can at least break the connection.)

Expected Results:  As expected, it prompts you for a password.

After entering the password, it quickly executes the command specified.
(In my example, it would show a directory listing.)

Affects rsh-server-0.17-2.2.
Comment 1 Bill Nottingham 2001-03-27 16:37:30 EST

*** This bug has been marked as a duplicate of 18107 ***

Note You need to log in before you can comment on or make changes to this bug.