This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 334821 - [RHEL 5.2] Xen 3.1.1 Prevent migration with attached PCI devices
[RHEL 5.2] Xen 3.1.1 Prevent migration with attached PCI devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks: 492190
  Show dependency treegraph
 
Reported: 2007-10-16 13:08 EDT by Cole Robinson
Modified: 2014-02-02 17:36 EST (History)
4 users (show)

See Also:
Fixed In Version: xen-3.0.3-85.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:09:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xen migration with attached PCI devices patch (1.31 KB, patch)
2009-03-09 05:36 EDT, Michal Novotny
no flags Details | Diff
Xen migration with attached PCI devices patch (1.32 KB, patch)
2009-04-29 13:03 EDT, Jiri Denemark
no flags Details | Diff
Fixed patch preventing migrations of domains with attached PCI devices (1.27 KB, patch)
2009-04-30 07:02 EDT, Jiri Denemark
no flags Details | Diff

  None (edit)
Description Cole Robinson 2007-10-16 13:08:36 EDT
The following csets are from xen-3.1-testing.hg, which prevent a domain from
migrating with attached PCI devices, as it sure shouldn't work. These are
recommended for inclusion in RHEL 5.2.

  15265 - prevent domains from migrating with attached pci devices,
          fixes potential whole machine crash
  15266 - pass migration failure due to PCI ownership info to user
Comment 1 RHEL Product and Program Management 2007-10-16 13:14:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 RHEL Product and Program Management 2008-03-11 15:39:28 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 3 Michal Novotny 2009-03-09 05:36:38 EDT
Created attachment 334484 [details]
Xen migration with attached PCI devices patch

This is a patch to prevent Xen migration with attached PCI devices and also passing this information to user. It's a backport of upstream at http://xenbits.xensource.com/xen-3.1-testing.hg?rev/15af4202c910 and http://xenbits.xensource.com/xen-3.1-testing.hg?rev/1b4954867329 .
Comment 4 Jiri Denemark 2009-04-29 13:03:21 EDT
Created attachment 341790 [details]
Xen migration with attached PCI devices patch

Adjusted to apply cleanly with no hard tabs
Comment 5 Jiri Denemark 2009-04-29 13:23:45 EDT
Fix built into xen-3.0.3-84.el5
Comment 6 Jiri Denemark 2009-04-30 07:02:11 EDT
Created attachment 341903 [details]
Fixed patch preventing migrations of domains with attached PCI devices

The original patch would cause leaks of open file descriptors as the
os.close(fd) call after the try..except block is unreachable.

There are two possible ways of fixing that. Either remove the second hunk of
the patch and let the code be
    try:
        return XendCheckpoint.save(...)
    finally:
        os.close(fd)                   

or expand the finally statement (like the original patch did) and remove the
return keyword.

While expanding the finally statement is a stupid thing to do, I decided to
fix it that way to match upstream. The return keyword was removed upstream as
a tiny part of huge c/s 12071.
Comment 7 Jiri Denemark 2009-05-11 09:39:54 EDT
Fix built into xen-3.0.3-85.el5
Comment 11 errata-xmlrpc 2009-09-02 06:09:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1328.html

Note You need to log in before you can comment on or make changes to this bug.