Bug 334861 - [RHEL 5.2] Xen 3.1.1 Prevent windows UHCI USB crashes
Summary: [RHEL 5.2] Xen 3.1.1 Prevent windows UHCI USB crashes
Status: CLOSED DUPLICATE of bug 245574
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-16 17:25 UTC by Cole Robinson
Modified: 2009-12-14 21:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-24 16:36:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Cole Robinson 2007-10-16 17:25:24 UTC
The following csets claim to fix some UHCI USB related crashes in a windows guest. 
They are recommended for inclusion in RHEL 5.2.

  15154 - fix Qemu USB crashes on Windows
  15224 - rewrite Qemu memcpy_words from 15154 in assembler for x86
  15252 - Fix 15224 broken __x86_64
  15311 - another fix to memcpy_words (depends on 15224)

Comment 1 RHEL Product and Program Management 2007-10-16 18:04:43 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Cole Robinson 2007-10-18 16:17:06 UTC
I should mention the specified changesets are from xen-3.1-testing.hg

Comment 3 Cole Robinson 2007-10-22 16:17:11 UTC
An additional cset which adds a fix to memcpy_words, specific to IA64. We need
this if we are going to take any of the previously listed csets.

  15370 - tools: ioemu: avoid unaligned guest memory access on ia64


Comment 4 Chris Lalancette 2008-02-24 16:36:31 UTC
These patches were actually brought in by BZ 245574.  Closing this as a dup.

Chris Lalancette

*** This bug has been marked as a duplicate of 245574 ***


Note You need to log in before you can comment on or make changes to this bug.