This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 335141 - rpcbind service prevented from starting by a typo
rpcbind service prevented from starting by a typo
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
bzcl34nup
:
: 335751 337451 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 15:25 EDT by Michal Jaegermann
Modified: 2008-04-04 13:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 13:02:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-10-16 15:25:58 EDT
Description of problem:

In start() function of /etc/rc.d/init.d/rpcbind script there
is the following:

        # Check that networking is up.
        [ "$NETWORKING" = "no" ] || exit 6

So with $NETWORKING set to "yes", as you would expect this
terminated with a status 6 and no daemon is started.  You likely
intended "&&" instead of "||".

Does any other value but "no" indeed guarantees that networking is
up?  What about "NO", for example, no empty?

It looks like that as a side effect this is causing also non-zero
status from rpm while removing rpcbind-0.1.4-8.fc8 so one ends up
with a duplicate.  A subsequent 'rpm -e rpcbind-0.1.4-8.fc8'
succeeds as rpcbind is not running anymore.

Version-Release number of selected component (if applicable):
rpcbind-0.1.4-9.fc8
Comment 1 Mike Chambers 2007-10-16 16:00:27 EDT
This has already been fixed and you can find it at the below URL until the fix
hits rawhide...

http://koji.fedoraproject.org/koji/buildinfo?buildID=21252
Comment 2 Steve Dickson 2007-10-23 09:30:04 EDT
Fixed in rpcbind-0.1.4-10.fc8
Comment 3 Steve Dickson 2007-10-23 09:30:39 EDT
*** Bug 335751 has been marked as a duplicate of this bug. ***
Comment 4 Steve Dickson 2007-10-23 09:30:44 EDT
*** Bug 337451 has been marked as a duplicate of this bug. ***
Comment 5 Bug Zapper 2008-04-04 10:07:58 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Note You need to log in before you can comment on or make changes to this bug.