Bug 335751 - RPC.statd fails to start
RPC.statd fails to start
Status: CLOSED DUPLICATE of bug 335141
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 03:40 EDT by John Schmitt
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 09:30:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image of failure at boot (110.91 KB, image/png)
2007-10-17 03:40 EDT, John Schmitt
no flags Details
/var/log/messages (317.97 KB, application/octet-stream)
2007-10-17 03:43 EDT, John Schmitt
no flags Details
recreate the error message after the machine has booted (1.11 KB, text/plain)
2007-10-17 03:46 EDT, John Schmitt
no flags Details
/etc/fstab used to create the problem (665 bytes, text/plain)
2007-10-17 03:47 EDT, John Schmitt
no flags Details
Var/log/messages after boot with 2.6.23-6.fc8 kernel (Fedora 8 test 3) (310.58 KB, application/octet-stream)
2007-10-18 02:49 EDT, Kari Pietarinen
no flags Details

  None (edit)
Description John Schmitt 2007-10-17 03:40:56 EDT
Description of problem:
Cannot mount anything via NFS.

Version-Release number of selected component (if applicable):
Linux linuxf8 2.6.23-6.fc8 #1 SMP Thu Oct 11 13:36:39 EDT 2007 x86_64 x86_64
x86_64 GNU/Linux
Happens with these two kernels:
kernel-2.6.23-5.fc8
kernel-2.6.23-6.fc8

How reproducible:
Everytime

Steps to Reproduce:
1. Mount my home directory in /etc/fstab
2. Boot
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Schmitt 2007-10-17 03:40:56 EDT
Created attachment 229601 [details]
image of failure at boot
Comment 2 John Schmitt 2007-10-17 03:43:06 EDT
Created attachment 229611 [details]
/var/log/messages
Comment 3 John Schmitt 2007-10-17 03:46:19 EDT
Created attachment 229631 [details]
recreate the error message after the machine has booted
Comment 4 John Schmitt 2007-10-17 03:47:08 EDT
Created attachment 229641 [details]
/etc/fstab used to create the problem
Comment 5 Kari Pietarinen 2007-10-18 02:44:14 EDT
NFS partitions can not be mounted during boot or by the super user(root). 

If NFS partitions are mounted manually as root "mount /mountpoint", following
error is given "mount.nfs: rpc.statd is not running but is required for remote
locking Either use "-o nolocks" to keep locks local, or start statd.". 

Following is an example line in fstab file: 
"machine.domain.fi:/export/home     /mountpoint            nfs   
resize=8192,wsize=8192 0 0"
Comment 6 Kari Pietarinen 2007-10-18 02:49:12 EDT
Created attachment 230731 [details]
Var/log/messages after boot with  2.6.23-6.fc8 kernel (Fedora 8 test 3)
Comment 7 John Schmitt 2007-10-19 19:33:34 EDT
I can kinda work around this by booting to runlevel 3.  I invoke:

$ rpcbind -d

and then in another shell I invoke:

$ service nfs restart
$ mount -a

and I seem to be able to mount my home directory again.
Comment 8 Steve Dickson 2007-10-23 09:30:38 EDT

*** This bug has been marked as a duplicate of 335141 ***

Note You need to log in before you can comment on or make changes to this bug.