Bug 33579 - printconf configures smb printer correctly but won't connect to printer
printconf configures smb printer correctly but won't connect to printer
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-28 02:52 EST by Paul Watkins
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 04:46:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Watkins 2001-03-28 02:52:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.28 i686)


printconf appears to configure a samba printer share on a remote windows
machine correctly . After installing wolverine, the printer cannot be
accessed.  No error messages are generated, even the the log active in
/tmp.  Printing appears to work but no printing appears.  Networking
connections are all correct and other samba shares work. I've held off on
reporting this but see that others in the wolverine list have experienced
the same difficulties.

Reproducible: Always
Steps to Reproduce:
1.use printconf to configure remote samba printer on a windows nt box
2. print test pages -- no pages appear
3. queue monitor program shows items in the queue, printing and then being
removed from the queue.
4. Nothing appears at the printer -- all samba configs seem to be correct
--worked before wolverine.
	

Actual Results:  Nothing -- no printing, no errors, no log errors

Expected Results:  Printed pages
Comment 1 Crutcher Dunnavant 2001-03-28 16:36:45 EST
yes.

This is a by-product of a very complex network interaction problem that is fixed
now. Sorry for the inconveinence.
Comment 2 Paul Watkins 2001-03-28 18:12:06 EST
Since I'm still experiencing this problem after having used up2date to get the
latest beta fixes, does that mean the bug still exists or that the fix hasn't
been made available yet?
Comment 3 Crutcher Dunnavant 2001-03-29 15:28:02 EST
Okay...
maybe you are seeing a different error.

please submit the results of:

	rpm -q LPRng
	rpm -q printconf
	rpm -q printconf-gui

as well as attaching a copy of

	/etc/alchemist/namespace/printconf/local.adl

do you know how to use smbclient to print directly? if you do, could you see if
that works?
Comment 4 Dave Weis 2001-04-23 16:03:50 EDT
I'm also experiencing this on a machine upgraded from 6.2 that worked
successfully. Below is my info:
[tbibbs@dhcp33 printconf]$ rpm -q LPRng
LPRng-3.7.4-22
[tbibbs@dhcp33 printconf]$ rpm -q printconf
printconf-0.2.12-1
[tbibbs@dhcp33 printconf]$ rpm -q printconf-gui
printconf-gui-0.2.12-1

Comment 5 Paul Watkins 2001-04-23 21:58:27 EDT
With the latest beta update of wolverine -- about 2 or 3 days before the formal
release of seawolf, the samba printer worked fine.  I could configure it
properly with the printconf tool and all my samba network boxes can see the
samba printer share on the Win NT box and use it. smbprint works fine in
standalone mode.

I have not gotten around to installing seawolf yet to see if the samba printers
continue to work as they do now.
Comment 6 dkaplan 2001-05-09 20:59:11 EDT
I also cannot get SMB printers to work with printconf.  The same printers work
just fine if I downgrade to the old printtool utility and recreate the
configuration.

In my case it goes through a series of attempts to print (3).  After that it
removes the file and nothing comes out.  The output of lpq looks like:

Printer: bongo@volcan
 Queue: 1 printable job
 Server: pid 4575 active
 Unspooler: pid 4590 active
 Status: attempt 2, sleeping 10 before retry at 20:59:55.186
 Rank   Owner/ID                  Class Job Files                 Size Time
active(attempt-2) root              A   574 /usr/share/printconf 18043 20:59:54

and then

Printer: bongo@volcan
 Queue: no printable jobs in queue
 Status: removing job 'cfA574volcan.ucdavis.edu' - JREMOVE at 21:00:26.116

I am using the following rpms.

LPRng-3.7.4-22
printconf-0.2.12-1
printconf-gui-0.2.12-1

Hopefully this can be fixed soon.  Otherwise printconf seems like a nice
improvement over printtool.

Thanks,
David Kaplan
Comment 7 Bill McCarty 2001-05-13 16:34:13 EDT
The print-conf tool builds a /var/spool/lpd/*/script.cfg file that looks like 
this:

share="\intel\lj2100"
hostip="hostname"
user="userid"
password="password"
workgroup="workgroup"
translate="yes"

Instead, it should look like this:

share="\\intel\lj2100"
hostip="hostname"
user="userid"
password="password"
workgroup="workgroup"
translate="yes"

The shell is interpreting the \\ specified in the gui and putting only a single 
\ in script.cfg. Workaround: manually edit script.cfg. 

Comment 8 Bill McCarty 2001-05-13 16:47:01 EDT
Phooey! Now, I'm doing it--correction follows....

The print-conf tool builds a /var/spool/lpd/*/script.cfg file that looks like 
this:

share="\\intel\lj2100"
hostip="hostname"
user="userid"
password="password"
workgroup="workgroup"
translate="yes"

Instead, it should look like this:

share="\\\\intel\\lj2100"
hostip="hostname"
user="userid"
password="password"
workgroup="workgroup"
translate="yes"

Workaround: double the number of slashes entered in printconf's text box.
Comment 9 Need Real Name 2001-05-15 00:16:13 EDT
>Workaround: double the number of slashes entered in printconf's text box.

It does solve my problem! 

In fact, I get something from the windows print server, but nothing ever comes out of the printer. The
HP driver eventually complains of a timeout.

Please! You need to fix this!!! I used to be able to print to a samba share in RedHat 6.x. THIS is a 
big deal for me!!! At the very least, provide a workaround that works!
Comment 10 Need Real Name 2001-05-15 00:19:45 EDT
I meant to say it doesn't solve my problem.... arghhh! I'm loosing my mind over this...

By the way, I can manage to print using smbclient...well, at least print some text...

So the trouble is definitively with printconf!!
Comment 11 Soren Roug 2001-05-17 04:46:21 EDT
bmccarty@apu.edu mentioned that you should double the backslashes in the share 
name. While it will work, My opinion is that instead of using quotes (") use 
apostrophes (') in script.cfg. That way the shell won't evaluate the string.

So it really is a bug in the program, that writes the script.cfg file. And yes, 
it works for me now (Redhat 7.1).
Comment 12 Crutcher Dunnavant 2001-08-01 16:45:47 EDT
oh. oops.

Note You need to log in before you can comment on or make changes to this bug.