Bug 33594 - Upgrade Failure Received this file
Summary: Upgrade Failure Received this file
Status: CLOSED DUPLICATE of bug 18900
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-28 13:45 UTC by John Wright
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 21:27:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Wright 2001-03-28 13:45:23 UTC
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in 
run
    rc = apply (step[1](), (dir,) + step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in 
__call__
    todo.upgradeFindPackages (root)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 910, in 
upgradeFindPackages
    fstab.readFstab('/mnt/sysimage/etc/fstab', self.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 1021, in 
readFstab
    device = labelsByMount[label]
KeyError: /archiv

Local variables in innermost frame:
loopIndex: {}
fstab: <fstab.NewtFstab instance at 8215450>
labelsByMount: {'/usr': 'hda5', '/': 'hda1', '/home': 'hda6'}
line: LABEL=/archiv           /archiv                 ext2    
defaults        1 2

path: /mnt/sysimage/etc/fstab
device: hda1
raidByDev: {}
label: /archiv
fsystem: ext2
drives: ['hda']
lines: ['LABEL=/                 /                       ext2    
defaults        1 1\012', 'LABEL=/archiv           /archiv                 
ext2    defaults        1 2
\012', 'LABEL=/home             /home                   ext2    
defaults        1 2\012', '/dev/cdrom              /mnt/cdrom              
iso9660 noauto,owner,ro 0 0
\012', '/dev/fd0                /mnt/floppy             auto    
noauto,owner    0 0\012', 'LABEL=/usr              /usr                    
ext2    defaults        1 2
\012', 'none                    /proc                   proc    
defaults        0 0\012', 'none                    /dev/pts                
devpts  gid=5,mode=620  0 0\012', '/dev/hda7               
swap                    swap    defaults        0 0\012']
labels: {'hda5': '/usr', 'hda1': '/', 'hda6': '/home'}
fields: ['LABEL=/archiv', '/archiv', 'ext2', 'defaults', '1', '2']
f: <open file '/mnt/sysimage/etc/fstab', mode 'r' at 822ff30>
raidList: []

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Brent Fox 2001-03-29 19:25:08 UTC
Can you attach your /etc/fstab file?

Comment 2 Brent Fox 2001-03-30 21:27:32 UTC
This bug looks alot like bug #27129

Comment 3 Brent Fox 2001-03-30 21:32:18 UTC

*** This bug has been marked as a duplicate of 18900 ***


Note You need to log in before you can comment on or make changes to this bug.