Bug 335961 - kernel BUG at arch/i386/mm/hypervisor.c:185
kernel BUG at arch/i386/mm/hypervisor.c:185
Status: CLOSED DUPLICATE of bug 252301
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 06:57 EDT by Jakub Hrozek
Modified: 2009-12-14 15:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 08:55:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2007-10-17 06:57:12 EDT
Description of problem:
Oct 17 12:50:44 jarilo kernel: kernel BUG at arch/i386/mm/hypervisor.c:185!
Oct 17 12:50:44 jarilo kernel: invalid opcode: 0000 [#2]
Oct 17 12:50:44 jarilo kernel: SMP
Oct 17 12:50:44 jarilo kernel: last sysfs 
file: /devices/pci0000:00/0000:00:1c.0/0000:02:00.0/irq
Oct 17 12:50:44 jarilo kernel: Modules linked in: vfat fat usb_storage nfsd 
exportfs ppdev lp loop appletalk ipx p8023 netbk xenblktap blkbk bridge 
autofs4
xt_tcpudp ip6t_REJECT ip6table_filter ip6_tables x_tables hidp nfs nfs_acl 
rfcomm l2cap bluetooth lockd sunrpc dm_mirror dm_multipath dm_mod video sbs 
i2c_e
c dock button battery asus_acpi backlight ac ipv6 snd_intel8x0 snd_ac97_codec 
ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device s
nd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc 
serial_core parport_pc parport iTCO_wdt iTCO_vendor_support tg3 i2c_i801 
serio_raw i
2c_core pcspkr floppy sr_mod cdrom sg ata_piix ata_generic libata sd_mod 
scsi_mod ext3 jbd mbcache ehci_hcd ohci_hcd uhci_hcd
Oct 17 12:50:44 jarilo kernel: CPU:    0
Oct 17 12:50:44 jarilo kernel: EIP:    0061:[<c101811c>]    Not tainted VLI
Oct 17 12:50:44 jarilo kernel: EFLAGS: 00010282   (2.6.20-2931.fc7xen #1)
Oct 17 12:50:44 jarilo kernel: EIP is at xen_pgd_pin+0x57/0x62
Oct 17 12:50:44 jarilo kernel: eax: ffffffea   ebx: dac1eebc   ecx: 00000001   
edx: 00000000
Oct 17 12:50:44 jarilo kernel: esi: 00007ff0   edi: 00000000   ebp: dac1eed0   
esp: dac1eebc
Oct 17 12:50:44 jarilo kernel: ds: 007b   es: 007b   ss: 0069
Oct 17 12:50:44 jarilo kernel: Process bash (pid: 29951, ti=dac1e000 
task=eae80030 task.ti=dac1e000)
Oct 17 12:50:44 jarilo kernel: Stack: 00000002 00059a3e 2543e000 004a87c0 
ea793300 dac1eedc c1014315 ea79336c
Oct 17 12:50:45 jarilo kernel:        dac1eeec c1014345 e0bf08b4 00000000 
dac1eef4 c1014dbc dac1ef44 c101e8a0
Oct 17 12:50:45 jarilo kernel:        e0bf0560 00007505 c12fa300 dac1efb8 
bfa90c94 01200011 00000000 d54f6070
Oct 17 12:50:45 jarilo kernel: Call Trace:
Oct 17 12:50:45 jarilo kernel:  [<c1005e4a>] show_trace_log_lvl+0x1a/0x2f
Oct 17 12:50:45 jarilo kernel:  [<c1005efa>] show_stack_log_lvl+0x9b/0xa3
Oct 17 12:50:45 jarilo kernel:  [<c1006096>] show_registers+0x194/0x26a
Oct 17 12:50:45 jarilo kernel:  [<c10062a6>] die+0x13a/0x24f
Oct 17 12:50:45 jarilo kernel:  [<c11fbc73>] do_trap+0x79/0x91
Oct 17 12:50:45 jarilo kernel:  [<c100684f>] do_invalid_op+0x97/0xa1
Oct 17 12:50:45 jarilo kernel:  [<c11fbb5d>] error_code+0x35/0x3c
Oct 17 12:50:45 jarilo kernel:  [<c1014315>] __pgd_pin+0x32/0x40
Oct 17 12:50:45 jarilo kernel:  [<c1014345>] mm_pin+0x22/0x2d
Oct 17 12:50:45 jarilo kernel:  [<c1014dbc>] _arch_dup_mmap+0x27/0x29
Oct 17 12:50:45 jarilo kernel:  [<c101e8a0>] copy_process+0xb25/0x1135
Oct 17 12:50:46 jarilo kernel:  [<c101ef00>] do_fork+0x50/0x117
Oct 17 12:50:46 jarilo kernel:  [<c1003229>] sys_clone+0x33/0x39
Oct 17 12:50:46 jarilo kernel:  [<c1005660>] syscall_call+0x7/0xb
Oct 17 12:50:46 jarilo kernel:  =======================
Oct 17 12:50:46 jarilo kernel: Code: eb fe a1 24 42 38 c1 8b 14 90 81 e2 ff ff 
ff 7f 89 55 f0 8d 5d ec b9 01 00 00 00 31 d2 be f0 7f 00 00 e8 28 92 fe ff 85
 c0 79 04 <0f> 0b eb fe 83 c4 0c 5b 5e 5d c3 55 89 c2 89 e5 56 53 83 ec 0c
Oct 17 12:50:46 jarilo kernel: EIP: [<c101811c>] xen_pgd_pin+0x57/0x62 SS:ESP 
0069:dac1eebc


Version-Release number of selected component (if applicable):
2.6.20-2931.fc7xen

How reproducible:
not sure, happened just once

Steps to Reproduce:
in my case, that was "open xterm"
  
Actual results:
kernel bug

Additional info:
I'm unsure about what information should a good kernel bug report have..just 
holler if you need to know anything else
Comment 1 Eduardo Habkost 2007-10-17 08:55:02 EDT
This problem should be solved on kernel-xen 2.6.20-2934.fc7 or later (bug 
#252301).

*** This bug has been marked as a duplicate of 252301 ***

Note You need to log in before you can comment on or make changes to this bug.