Bug 336221 - Enhancement: enable "ldap_sasl_bind" feature for php-ldap
Enhancement: enable "ldap_sasl_bind" feature for php-ldap
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 10:32 EDT by Ryan Curtin
Modified: 2008-05-21 10:31 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0327
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:31:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Curtin 2007-10-17 10:32:27 EDT
+++ This bug was initially created as a clone of Bug #205772 +++

Consider a possibility to provide SASL authentication for PHP ldap module,
i.e. use "--with-ldap-sasl" when configure. With this option, an additional
function "ldap_sasl_bind" will appear.

Note, that the current ldap.so module already depends on libsasl2 (see ldd
/usr/lib/php/modules/ldap.so), because ldap libraries already compiled with sasl
support. It means that nothing too big will be added anyway...

-- Additional comment from jorton@redhat.com on 2007-03-29 10:36 EST --
This is done in Raw Hide now; thanks for the suggestion.

---
I checked the SRPM at
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/php-5.1.6-15.el5.src.rpm
and did not find the --with-ldap-sasl option.
Comment 6 errata-xmlrpc 2008-05-21 10:31:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0327.html

Note You need to log in before you can comment on or make changes to this bug.