This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 33633 - openssh-2.5.2p2 upgrade kills master sshd, won't restart
openssh-2.5.2p2 upgrade kills master sshd, won't restart
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: openssh (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 33122 33851 33912 33977 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-28 12:50 EST by Pekka Savola
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 20:59:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2001-03-28 12:50:49 EST
openssh-2.5.2p2-1.7
initscripts-5.49-1

After upgrading from 2.3.0p4, I get to the syslog:

Mar 28 20:08:57 xxx sshd[761]: Received signal 15; terminating.
Mar 28 20:08:57 xxx sshd: sshd shutdown succeeded
Mar 28 20:08:59 xxx sshd: RSA key generation succeeded

At this point, master sshd daemon has been killed and /var/run/sshd.pid
deleted.

Now, 'service sshd start' won't start the daemon; no error messages are
printed.  This
is caused by some bug in 'daemon' code of initscripts (misdetecting current
ssh connections
as the master process?), as '/usr/sbin/sshd' works fine.

There are two ways the next step happens:
 1) if you're on console, 'service sshd restart' kills _ONE_ connected ssh
client and otherwise
restarts gracefully.
 2) if you're connected with ssh, 'service sshd restart' kills your
connection but won't start a new
one.  Time to walk to the console..

The fact that all systems AFAIR had at least one incoming sshd client
process running at the time sshd was restarted might have been crucial.

This has been replicated on 5+ systems.
Comment 1 Preston Brown 2001-03-28 14:53:10 EST
Bill, this definitely has to be a problem with the "daemon" initscripts 
function.
Comment 2 Bill Nottingham 2001-03-28 15:38:15 EST
Yes. It was fixed between 7.0 and one of the various betas (the betas
don't have this problem...)
Comment 3 Bill Nottingham 2001-03-29 10:54:03 EST
*** Bug 33851 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2001-03-29 14:58:42 EST
*** Bug 33912 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2001-03-29 20:59:13 EST
*** Bug 33977 has been marked as a duplicate of this bug. ***
Comment 6 Nalin Dahyabhai 2001-04-02 19:59:19 EDT
Fixed in openssh-2.5.2p2-1.7.2.
Comment 7 Pekka Savola 2001-04-14 16:44:14 EDT
*** Bug 33122 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.