Bug 33711 - rpm fails on install with default Wolverine install
Summary: rpm fails on install with default Wolverine install
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-28 23:20 UTC by Bruce Tenison
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 23:20:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruce Tenison 2001-03-28 23:20:31 UTC
I installed Wolverine and noticed that rpm -Uhv command fail with a
core dump.  On inspection of the core and little backtracing, it seems
that rpm is dumping core on line 1043 of lib/install.c in rpm-4.0.2.
It is the line that reads:  (void)getpwnam("root");

I dunno if this is a glibc error, something specific to my system somewhere
or an rpm problem (since getpwnam returns a struct passwd *?!?!?)

Comment 1 Jeff Johnson 2001-03-29 14:12:49 UTC
Are you sure the seg fault is at line 1043? If so, this isn't an rpm problem.
If you can't look up root, then you need to look at how your machine
has configured password services, and what glibc packages you have installed.

FWIW, rpm is one of the only statically linked binaries on a system
and that can lead to problems when, for example, a glibc structure changes
incompatibly. However, I'm unaware (and it's a BIG noise when it happens :-) of
any incompatibility problems since glibc-2.1.92.

Comment 2 Bruce Tenison 2001-03-29 14:58:33 UTC
Thanks!!!!!  Your hint pointed me in the right direction.  Somehow (I don't
remember EVER messing with /etc/nsswitch.conf) the passwd and shadow lines had
ldap before files in the lines.  Example:  passwd ldap files nisplus nis

I removed ldap, and all works, now!  Thanks and sorry to bother ya.


Note You need to log in before you can comment on or make changes to this bug.