Bug 337161 - system-config-kickstart crashes due to an AttributeError
system-config-kickstart crashes due to an AttributeError
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 426127 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 02:02 EDT by Jonas Weismueller
Modified: 2014-01-21 17:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 11:35:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback of the crash (1021 bytes, text/plain)
2007-10-18 02:02 EDT, Jonas Weismueller
no flags Details

  None (edit)
Description Jonas Weismueller 2007-10-18 02:02:20 EDT
Description of problem:
During the dialog "Retrieve Package Information" the application crashes with
the traceback attached.


Version-Release number of selected component (if applicable):
pykickstart-1.13-2.fc7
system-config-kickstart-2.7.7.1-1.fc7

How reproducible:
start system-config-kickstart from console and wait

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Maybe it is due to a self mirror repository which does not contain all necessary
information than an offical repository.
Comment 1 Jonas Weismueller 2007-10-18 02:02:20 EDT
Created attachment 230711 [details]
Traceback of the crash
Comment 2 Tim Lauridsen 2007-10-18 10:41:14 EDT
This is not an yum issue, the is a typo in 
/usr/share/system-config-kickstart/packages.py

 except yum.Error.RepoError:

should have been 
 except yum.Errors.RepoError:

Comment 3 Seth Vidal 2007-10-18 10:42:58 EDT
looks like the import is just wrong in s-c-ks.

it's yum.Errors.RepoError, not yum.Error.RepoError

line 143 of packages.py just needs to be edited to be Errors.
Comment 4 Jonas Weismueller 2007-10-18 10:46:08 EDT
Errors seems to fix the bug. Thanks.
Comment 5 Chris Lumens 2007-10-18 11:35:53 EDT
Tim, Seth:  Thanks for the catch there.
Comment 6 Chris Lumens 2007-12-18 13:25:10 EST
*** Bug 426127 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.