Bug 3373 - 'exec' feature creates zombie processes
'exec' feature creates zombie processes
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: swatch (Show other bugs)
6.0
All Linux
high Severity high
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-09 16:51 EDT by rotten
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-31 13:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rotten 1999-06-09 16:51:04 EDT
When using the 'exec=command' feature in the 2nd
tab-deliminated field of the ~/.swatchrc, the command
executed does not terminate properly when it is finished--
it becomes a zombie process, every time (this has been
tested using such innocuous commands as 'exec=echo').

When swatch is triggered enough times, the zombie processes
build up, eventually filling the process table and thus
requiring a reboot.
Comment 1 Alan Cox 1999-06-12 11:19:59 EDT
You can clear the zombies by killing their parent. So killing swatch
will clean up the stuff it fails to wait for.
(Not a fix but avoids reboots)


------- Additional Comments From   06/12/99 12:44 -------
Not to split hairs, but I think it is worth noting that killing swatch
will not successfully clean up the zombie processes, nor prevent more
from being spawned... it is necessary to kill perl itself.
And a side note-- this bug is particularly detrimental on unattended
machines, since killing perl isn't an option in that situation.
Comment 2 Jay Turner 1999-06-29 11:10:59 EDT
This issue has been forwarded to a developer for further action.
Comment 3 Preston Brown 1999-08-31 13:22:59 EDT
fixed in swatch-2.2-8 and later, available soon in RawHide and
eventually our next release.

Note You need to log in before you can comment on or make changes to this bug.