Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 33732 - QA0327 - time.h problem --?--
QA0327 - time.h problem --?--
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-28 21:44 EST by R P Herrold
Modified: 2016-11-24 10:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 21:45:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2001-03-28 21:44:07 EST
Compiling the EveryBuddy instant message SRPM -- available at
http://www.everybuddy.com/download.shtml -- version everybuddy-0.2.0/ -
this package built, installed, and runs fine under RH 6.2, patched fully
current.  It will not build, seemingly due to a time.h library problem ... 
As I recall, this was an issue with the plex386 package as well, in
discussion on the testers-list.  tail of build attempt below.

-----------------------------------------------------------------


gcc -DPACKAGE=\"everybuddy\" -DVERSION=\"0.2.0\" -DUNIX=1 -DSTDC_HEADERS=1
-DHAVE_SYS_WAIT_H=1 -DHAVE_FCNTL_H=1 -DHAVE_SYS_TIME_H=1 -DHAVE_UNISTD_H=1
-DHAVE_GETOPT_H=1 -DHAVE_ICONV_H=1 -DRETSIGTYPE=void -DHAVE_STRFTIME=1
-DHAVE_SOCKET=1 -DHAVE_STRDUP=1 -DHAVE_STRSTR=1 -DHAVE_ATEXIT=1
-DHAVE_STRSEP=1 -DHAVE_GETHOSTBYNAME2=1 -DHAVE_STRTOK_R=1
-DHAVE_MIT_SAVER_EXTENSION=1 -DHAVE_SNPRINTF=1 -DHAVE_LIBNSL=1
-DHAVE_LIBSOCKET=1  -I. -I.      -O2 -march=i386 -mcpu=i686 -DHAVE_ISPELL
-I/usr/local/include -I/opt/include -I../ -D_REENTRANT -Wall -g  
-DESD_SOUND -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I../src -I../libproxy  -I./include/jabber 
-I./include       -I../libxode/include  -c jutil.c
jutil.c: In function `jutil_timestamp':
jutil.c:156: warning: implicit declaration of function `time'
jutil.c:160: warning: implicit declaration of function `gmtime'
jutil.c:160: warning: assignment makes pointer from integer without a cast
jutil.c:162: dereferencing pointer to incomplete type
jutil.c:163: dereferencing pointer to incomplete type
jutil.c:163: dereferencing pointer to incomplete type
jutil.c:163: dereferencing pointer to incomplete type
jutil.c:164: dereferencing pointer to incomplete type
jutil.c:164: dereferencing pointer to incomplete type
make[2]: *** [jutil.o] Error 1
make[2]: Leaving directory
`/usr/src/redhat/BUILD/everybuddy-0.2.0/libjabber'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/usr/src/redhat/BUILD/everybuddy-0.2.0/libjabber'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.62772 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.62772 (%build)
[root@couch SPECS]#
Comment 1 Bill Nottingham 2001-03-28 22:06:44 EST
It needs to include both <time.h> and <sys/time.h>.

Note You need to log in before you can comment on or make changes to this bug.