Bug 337611 - Kernel panic after installation and reboot, RHEL 5.1b Client Snap8 on RAID0 with dmraid [NEEDINFO]
Kernel panic after installation and reboot, RHEL 5.1b Client Snap8 on RAID0 w...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dmraid (Show other bugs)
5.1
i686 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Heinz Mauelshagen
Dean Jansa
: OtherQA, ZStream
Depends On:
Blocks: 466213
  Show dependency treegraph
 
Reported: 2007-10-18 05:45 EDT by Bartosz Barcinski
Modified: 2010-10-22 15:35 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:47:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cward: needinfo? (bartosz.barcinski)


Attachments (Terms of Use)

  None (edit)
Description Bartosz Barcinski 2007-10-18 05:45:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Description of problem:
After OS installation and reboot system partitions cannot be mounted. Below mentioned message is printed:

No RAID sets and with names: "isw_eedccagj_Volume0" 
Failed to stat() /dev/mapper/isw_eedccagj_Volume0
Buffer I/O error on device sda3, logical block 484086528
Buffer I/O error on device sda3, logical block 484086529
Buffer I/O error on device sda3, logical block 484086530
Buffer I/O error on device sda3, logical block 484086531
Buffer I/O error on device sda3, logical block 484086528
Buffer I/O error on device sda3, logical block 484086529
Buffer I/O error on device sda3, logical block 484086530
Buffer I/O error on device sda3, logical block 484086531
Unable to access resume device (LABEL=SWAP-isw_eedcca)
Buffer I/O error on device sda3, logical block 484086528
Buffer I/O error on device sda3, logical block 484086529
mount: could not find filesystem '/dev/root'
setuproot: moving /dev/failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempt to kill init!

OS: Linux gklab-56-033 2.6.18-48.el5 #1 SMP Mon Sep 17 17:26:31 EDT 2007 i686 i686 i386 GNU/Linux
DMRAID: dmraid-1.0.0.rc13-4.el5 
DEVICE-MAPPER: device-mapper-1.02.20-1.el5

Command dmraid -V returns:
dmraid version:		1.0.0.rc13 (2007.06.27) debug 
dmraid library version:	1.0.0.rc13 (2007.06.27)
device-mapper version:	4.11.0

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc13-4.el5, device-mapper-1.02.20-1.el5

How reproducible:
Always


Steps to Reproduce:
Connect 2 HDD SATA disks 
Enter OROM
Create RAID Volume with configuration
Name: Volume0
RAID Level: RAID0 (Stripe)
Disks: Select Disks (not configurable)
Strip Size: 128KB
Capacity: 465.8 GB
Perform OS installation with partition layout:
/boot partition on /dev/mapper/isw_eedccagj_Volume0 with size 100MB and file system ext3 (as Primary Partition).
swap partition on /dev/mapper/isw_eedccagj_Volume0 with size 4096MB (as Primary Partition).
/ partition on /dev/mapper/isw_eedccagj_Volume0 with remaining hdd capacity and file system ext3 (as Primary Partition).
Reboot PC

Actual Results:
OS cannot boot up (kernel panic, see description).

Expected Results:
Proper OS boot without problems.

Additional info:
There were no such problems on Fedora 7 
Linux localhost.localdomain 2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:35:01 EDT 2007 i686 i686 i386 GNU/Linux
dmraid-1.0.0.rc14-2.fc7
device-mapper-1.02.17-7.fc7 
dmraid version:		1.0.0.rc14 (2006.11.08) debug 
dmraid library version:	1.0.0.rc14 (2006.11.08)
device-mapper version:	4.11.0
Comment 1 Bartosz Barcinski 2007-10-19 04:14:46 EDT
It was tested on Intel DP35DPM main board with ICH9. The OS was installed on an
Intel ICH9 SW RAID Volume.
Comment 3 Jason Gaston 2007-12-20 11:40:52 EST
I also reproduced this issue using the released version of RHEL5.1 x86_64 on 
two different ICH9R based systems using different hard drives.  I then 
verified that raid0 works using the released version of RHEL5.0.  Somewhere 
this got broken in the RHEL5.1 release.
Comment 4 Adam Cetnerowski 2008-01-09 08:36:22 EST
Similar problem:
Used HW platform: PC with DP35DP motherboard, Op-ROM v7.5.0.1017 ICH9R wRAID5, 3
Seagate Barracudda ST3160215AS 160GB HDDs connected to SATA ports 0,1 and 2. 
All 3 disks were set to RAID0 mode via OROM (strip 128kB, max available space)
and  RHEL5.1 Client beta, snapshot8 OS  was being installed via PXE server
(manual installation, no kickstart file, accepted volume partitioning suggested
by the system installer).

During voulme format the following error occured:

"An error occured trying to format VolGroup00/LogVol00. This problem is serious,
and the install can not continue. Press <Enter> to reboot your system. <OK>."
Comment 5 Khamit Ardashev 2008-05-15 21:52:36 EDT
same thing on same setup:
intel dp35dp, 3  500GB  seagate drives on ich9r raid.

FC9 release 
Comment 6 RHEL Product and Program Management 2008-06-13 15:08:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Rezwanul Kabir 2008-06-16 15:28:35 EDT
Duplicated the same issues described in the original posting and in comment#4 
with both RHEL5.1 and RHEL5.2 on a ICH9M-E based system. 
Comment 11 Peter Jones 2008-07-09 11:02:00 EDT
Can you please attach the whole log from booting up, rather than just a small
subset?  There's not enough information here to know what's going wrong.
Comment 12 Khamit Ardashev 2008-07-09 18:26:05 EDT
I would, if I could boot the system...

problem is with inird image file not including support for dmraid.

I found with newer fc7 kernels very similar situation:
they dropped support for device mapper from inird image. When I installed a new
kernel, I woudln't see raid array (system sees individual drives with corrupted
FS). Since RAID array is not system drive I am able to start dmraid manually,
activate raid array, and rebuild inird file with mkinitrd.
On next boot up system finds raid array automatically.

Obviously problem is in inird file.

Comment 15 Peter Jones 2008-07-17 17:29:52 EDT
Heinz, I don't think this is a mkinitrd or anaconda bug.  dmraid isn't doing the
right thing here:

[root@localhost ~]# dmraid -ay -i -p --test
isw_djfghhjdic_Volume0: 0 234436608 mirror core 2 131072 nosync 2 /dev/sda 0
/dev/sdb 0
[root@localhost ~]# dmraid -ay -i -p --test isw_djfghhjdic_Volume0
No RAID sets and with names: "isw_djfghhjdic_Volume0"
[root@localhost ~]# 
Comment 21 Heinz Mauelshagen 2008-07-30 09:30:14 EDT
This is fixed in current devel CVS.
Preparing a patch for 5.3.
Comment 23 Rezwanul Kabir 2008-07-30 11:30:30 EDT
Heinz

   Can you elaborate a bit on what was the root cause and what components 
needed fixing? This will serve as a future reference.
    Thanks..
    --rez
Comment 24 Heinz Mauelshagen 2008-07-31 04:33:56 EDT
Rezwanul,
dmraid didn't handle compound RAID sets in group sets properly (type t_group).
Only the superset's name of type t_group (e.g. isw_djfghhjdic)  could be used on
the command line but not any subset names (e.g. isw_djfghhjdic_Volume0).
Comment 30 Heinz Mauelshagen 2008-10-08 19:06:33 EDT
Fix in 5.3 qu candidate.
Comment 34 Chris Ward 2008-11-28 02:12:19 EST
Partners, this bug should be fixed in the latest RHEL 5.3 Snapshot. We believe that you have some interest in its correct functionality, so we're making a friendly request to send us some testing feedback. 

If you have a chance to test it, please share with us your findings. If you have successfully VERIFIED the fix, please add PartnerVerified to the Bugzilla keywords, along with a description of the results. Thanks!
Comment 35 Rezwanul Kabir 2008-12-01 17:29:06 EST
Tested on an ICH9M-E based system. I setup RAID1 through OptionROM and installed RHEL5.3 Snapshot 3. I proceeded with default partitioning scheme during install.

After the install, the very first time, the machine booted fine and went through the firstboot setup. However, all subsequent boots from then are failing. 

The system halts during boot and throws the GRUB command shell..
Comment 38 Heinz Mauelshagen 2008-12-02 11:56:51 EST
Is this just another incarnation of #471689 ?
Comment 42 Suzanne Yeghiayan 2008-12-03 14:36:53 EST
We believe this issue will be fixed in Snapshot 5 with anaconda bug 471689.
Moved back to status ON_QA.
Comment 45 Chris Ward 2008-12-18 04:42:57 EST
Intel, others, what's the latest testing status for this fix?
Comment 48 errata-xmlrpc 2009-01-20 15:47:21 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0078.html

Note You need to log in before you can comment on or make changes to this bug.