Bug 337871 - Artifacts on ATI X800 GT when desktop effects enabled
Artifacts on ATI X800 GT when desktop effects enabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 08:38 EDT by Joachim Frieben
Modified: 2007-12-15 14:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-15 14:07:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample screenshot of artifacts on ATI X800 GT caused by desktop effects (475.44 KB, image/png)
2007-10-18 08:38 EDT, Joachim Frieben
no flags Details
xorg.conf created by anaconda (606 bytes, text/plain)
2007-10-19 09:07 EDT, Joachim Frieben
no flags Details
Xorg.0.log from xorg.conf created by anaconda (68.34 KB, text/plain)
2007-10-19 09:08 EDT, Joachim Frieben
no flags Details
Xorg.0.log from launching X without xorg.conf (72.14 KB, text/plain)
2007-10-19 10:14 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2007-10-18 08:38:00 EDT
Description of problem:
After enabling desktop effects, the screen of 1400x1050 pixels is sort
of split up into a region of 1280x800+0+0 and the surrounding area.
New windows stretch to the inner boundary at 1280x800 when maximized.
They cannnot be resized beyond this limit.
A striking effect appears when the desktop cube is rotated. It looks as
if certain rectangular parts of the image were missing and the remaining
ones glued together at the 1280x800 boundary (see attached screenshot).
Eventually, a total lock up of the X server occurs. It's unclear whether
the system itself keeps on running or not.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.7.195-3.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Start GNOME session.
2. Enable desktop effects.
3. Rotate desktop cube.

Actual results:
Parts of the screen seem to be missing along the 1280x800 contour.

Expected results:
Desktop cube is rotated without any artifacts.

Additional info: the output of 'xrandr -q' reads
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 1600 x 1200
VGA-0 connected 1400x1050+0+0 (normal left inverted right x axis y axis)
364mm x 291mm
   1600x1200      75.0     59.9  
   1400x1050@75   75.0* 
   1280x1024      84.8     73.7     75.0     59.9  
   1024x768       84.9     75.1     60.0  
   800x600        84.9     75.0     60.3  
   640x480        84.6     75.0     60.0  
   720x400        70.1  
None disconnected (normal left inverted right x axis y axis)
DVI-0 unknown connection 1280x800+0+0 (normal left inverted right x axis
y axis) 0mm x 0mm
   1360x768       59.8     60.0  
   1280x800       60.0* 
   1152x864       60.0  
   1280x768       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  

The secondary device is active although it is disconnected. This should
not be the case, should it?
After disabling DVI-0 [xrandr --output DVI-0 --off], desktop effects work
as expected.
Comment 1 Joachim Frieben 2007-10-18 08:38:00 EDT
Created attachment 231011 [details]
Sample screenshot of artifacts on ATI X800 GT caused by desktop effects
Comment 2 Matěj Cepl 2007-10-18 17:56:17 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Joachim Frieben 2007-10-19 09:07:26 EDT
This is the output of 'xrandr -q' for xorg.xonf generated by anaconda:

Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1600 x 1200
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis)
364mm x 291mm
   1600x1200      85.0     75.0     59.9  
   1280x1024      84.8*    73.7     75.0     59.9  
   1024x768       84.9     75.1     60.0  
   800x600        84.9     75.0     60.3  
   640x480        84.6     75.0     60.0  
   720x400        70.1  
None disconnected (normal left inverted right x axis y axis)
DVI-0 unknown connection 1152x864+0+0 (normal left inverted right x axis
 y axis)
0mm x 0mm
   1360x768       59.8     60.0  
   1280x800       60.0  
   1152x864       60.0* 
   1280x768       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
Comment 4 Joachim Frieben 2007-10-19 09:07:59 EDT
Created attachment 232521 [details]
xorg.conf created by anaconda
Comment 5 Joachim Frieben 2007-10-19 09:08:37 EDT
Created attachment 232531 [details]
Xorg.0.log from xorg.conf created by anaconda
Comment 6 Joachim Frieben 2007-10-19 10:14:17 EDT
Created attachment 232601 [details]
Xorg.0.log from launching X without xorg.conf
Comment 7 Joachim Frieben 2007-12-15 14:07:44 EST
Issue settled in current rawhide.

Note You need to log in before you can comment on or make changes to this bug.