Bug 338191 - Evo hangs when GPG signing email
Summary: Evo hangs when GPG signing email
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-18 15:56 UTC by Paul W. Frields
Modified: 2018-04-11 14:13 UTC (History)
1 user (show)

Fixed In Version: 2.12.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-21 14:26:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of evolution (11.48 KB, text/plain)
2007-10-19 03:36 UTC, Matěj Cepl
no flags Details

Description Paul W. Frields 2007-10-18 15:56:30 UTC
Description of problem:
If I select GPG signing for an email and press Ctrl+Enter to send, Evo hangs
waiting for gpg, but does not present a dialog for me to enter my GPG key
passphrase.  This worked fine before this newest update.  This must be fixed for
F8 GA, since many contributors sign email to the lists.

Version-Release number of selected component (if applicable):
2.12.1-2.fc8

How reproducible:
Every time.

Steps to Reproduce:
1. Reply to email.
2. Select option for GPG signing.
3. Send mail with Ctrl+Enter.
  
Actual results:
Hang

Expected results:
Passphrase dialog and sent mail.

Comment 1 Matthew Barnes 2007-10-18 18:56:25 UTC
There was a 2nd part to the evolution-data-server-1.12.1-2.fc8 update that I
forgot to push.  Please try evolution-2.12.1-3.fc8 in tomorrow's Rawhide update
and let me know if that fixes the problem.

Comment 2 Matěj Cepl 2007-10-19 03:36:37 UTC
Created attachment 231991 [details]
backtrace of evolution

I think I've got this reproduced with the attached backtrace and the following
packages installed:

[matej@viklef ~]$ rpm -qa evolution\*
evolution-2.12.1-2.fc8
evolution-remove-duplicates-debuginfo-0.0.3-1.fc8
evolution-data-server-debuginfo-1.12.1-2.fc8
evolution-webcal-2.12.0-1.fc8
evolution-data-server-devel-1.12.1-2.fc8
evolution-bogofilter-0.2.0-5.fc7
evolution-debuginfo-2.12.1-2.fc8
evolution-data-server-1.12.1-2.fc8
evolution-remove-duplicates-0.0.3-1.fc8
[matej@viklef ~]$

Comment 3 Matthew Barnes 2007-10-19 04:10:28 UTC
Thanks for the backtrace.  It's hanging on password fetching like I suspected.

evolution-2.12.1-3.fc8 should fix it.

Comment 4 Matěj Cepl 2007-10-19 04:33:21 UTC
and yes it seems to work with evolution-2.12.1-3.

Comment 5 Paul W. Frields 2007-10-21 14:26:50 UTC
Fixed in Rawhide, thank you kindly Mr. Barnes! :-)


Note You need to log in before you can comment on or make changes to this bug.