Bug 338471 - Wrong Permissions on dav DAVLockDB Subdirectory
Wrong Permissions on dav DAVLockDB Subdirectory
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 13:31 EDT by Richi Plana
Modified: 2008-01-24 10:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 10:29:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richi Plana 2007-10-18 13:31:22 EDT
Description of problem:
The httpd daemon's DAV module cannot initialize its lock database because the
group permissions on the subdirectory (/var/lib/dav/) restricts it from doing
so. In a default install, the permissions are as follows:

drwx------  2 root apache /var/lib/dav/

Version-Release number of selected component (if applicable):
httpd-2.2.6-1.fc7

Additional info:

Perhaps a permissions configuration in the spec file is the right fix
Comment 1 Joe Orton 2007-10-22 06:11:13 EDT
It's specified as "apache.apache" in the spec file, so it shouldn't be owned by
root.  Was this an upgrade, fresh install, anaconda, yum? Any errors in
/root/install.log or /root/upgrade.log?
Comment 2 Richi Plana 2007-10-22 10:01:42 EDT
The Fedora 7 system referred to was a fresh install with updates applied
throughout the months. So it's hard to say what happened to the ownership and
the permissions. I've not audit logs that can tell for sure. I only found out
about it since I activated mod_dav for the first time when I reported the bug.

I guess it's NOTABUG with this version.
Comment 3 Joe Orton 2008-01-24 10:29:16 EST
Closing out lacking a repro case.  Perhaps some transient "adduser" failure.

Note You need to log in before you can comment on or make changes to this bug.