Bug 33850 - db2 isn't thread capable
Summary: db2 isn't thread capable
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: db2 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 56899 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-29 14:33 UTC by Nils Philippsen
Modified: 2013-07-02 22:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-16 11:03:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patcgh to use spinlocks on IA32 to be able to be used from a threaded application (578 bytes, patch)
2001-03-29 14:34 UTC, Nils Philippsen
no flags Details | Diff

Description Nils Philippsen 2001-03-29 14:33:43 UTC
As of db2-2.4.14-4 (or -5), db2 isn't built in a way that it uses
spinlocks (to be thread-safe). The attached patch fixes this problem (but
only on Intel IA32, other platforms will have to be treated individually).

Comment 1 Nils Philippsen 2001-03-29 14:34:41 UTC
Created attachment 14106 [details]
Patcgh to use spinlocks on IA32 to be able to be used from a threaded application

Comment 2 Jindrich Novy 2006-02-15 10:45:43 UTC
*** Bug 56899 has been marked as a duplicate of this bug. ***

Comment 3 Jindrich Novy 2006-02-15 12:14:42 UTC
Is it still a problem in current db4?

Comment 4 Nils Philippsen 2006-02-16 11:03:20 UTC
I honestly don't know as I haven't used Berkeley DB by myself in years. Feel
free to close this one.


Note You need to log in before you can comment on or make changes to this bug.