Bug 338721 - kernel 2.6.23.1-4 traps when trying to load ath5k module
kernel 2.6.23.1-4 traps when trying to load ath5k module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 15:49 EDT by Bryan Christ
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.23.1-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 08:59:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Christ 2007-10-18 15:49:42 EDT
Description of problem:

At boot time, the kernel 2.6.23.1-4 traps when trying to load ath5k module for
the integrated wireless NIC on the Compaq nc6000 business class notebook

Version-Release number of selected component (if applicable):


How reproducible:

Everytime

Steps to Reproduce:
1.  Use yum to update to 2.6.23.1-4 kernel on Fedora 7
2.
3.
  
Actual results:

Kernel traps when trying to load ath5k module

Expected results:


Additional info:

Fallback kernel 2.6.22.9-91 works fine.
Comment 1 Bryan Christ 2007-11-02 01:22:18 EDT
Kernel no longer traps with 2.6.23.1-10
Linux version 2.6.23.1-10.fc7 (kojibuilder@xenbuilder4.fedora.phx.redhat.com)
(gcc version 4.1.2 20070925

However, ath5k does not work correctly.  Error from dmesg as follows:

[bryanc@scooter ~]$ dmesg |grep ath
ath_pci 0000:02:04.0: can't get channels
ath_pci: probe of 0000:02:04.0 failed with error -22
Comment 2 John W. Linville 2007-11-02 08:59:46 EDT
ath5k is still a work in progress.  Please see bug 254192.

Closing this as CURRENTRELEASE, since the oops is gone.

Note You need to log in before you can comment on or make changes to this bug.