Bug 33896 - APIC error qa0328
Summary: APIC error qa0328
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-29 16:36 UTC by Rogelio Noriega
Modified: 2007-04-18 16:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-11 19:39:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg file (14.54 KB, text/plain)
2001-03-30 21:56 UTC, Glen Foster
no flags Details

Description Rogelio Noriega 2001-03-29 16:36:51 UTC
Dell WS220 displays the following APIC error attached is the complete 
dmesg log. 

testing the IO APIC.......................

IO APIC #2......
.... register #00: 02000000
.......    : physical APIC id: 02
.... register #01: 00170020
.......     : max redirection entries: 0017
.......     : IO APIC version: 0020
 WARNING: unexpected IO-APIC, please mail
          to linux-smp@vger.kernel.org
.... register #02: 00000000
.......     : arbitration: 00
.... IRQ redirection table:
 NR Log Phy Mask Trig IRR Pol Stat Dest Deli Vect:   
 00 000 00  1    0    0   0   0    0    0    00
 01 003 03  0    0    0   0   0    1    1    39
 02 003 03  0    0    0   0   0    1    1    31
 03 003 03  0    0    0   0   0    1    1    41
 04 003 03  0    0    0   0   0    1    1    49
 05 003 03  0    0    0   0   0    1    1    51
 06 003 03  0    0    0   0   0    1    1    59
 07 003 03  0    0    0   0   0    1    1    61
 08 003 03  0    0    0   0   0    1    1    69
 09 003 03  0    0    0   0   0    1    1    71
 0a 003 03  0    0    0   0   0    1    1    79
 0b 003 03  0    0    0   0   0    1    1    81
 0c 003 03  0    0    0   0   0    1    1    89
 0d 000 00  1    0    0   0   0    0    0    00
 0e 003 03  0    0    0   0   0    1    1    91
 0f 003 03  0    0    0   0   0    1    1    99
 10 003 03  1    1    0   1   0    1    1    A1
 11 003 03  1    1    0   1   0    1    1    A9
 12 003 03  1    1    0   1   0    1    1    B1
 13 003 03  1    1    0   1   0    1    1    B9
 14 000 00  1    0    0   0   0    0    0    00
 15 000 00  1    0    0   0   0    0    0    00
 16 000 00  1    0    0   0   0    0    0    00
 17 000 00  1    0    0   0   0    0    0    00
IRQ to pin mappings:
IRQ0 -> 0:2
IRQ1 -> 0:1
IRQ3 -> 0:3
IRQ4 -> 0:4
IRQ5 -> 0:5
IRQ6 -> 0:6
IRQ7 -> 0:7
IRQ8 -> 0:8
IRQ9 -> 0:9
IRQ10 -> 0:10
IRQ11 -> 0:11
IRQ12 -> 0:12
IRQ14 -> 0:14
IRQ15 -> 0:15
IRQ16 -> 0:16
IRQ17 -> 0:17
IRQ18 -> 0:18
IRQ19 -> 0:19
.................................... done.

Comment 1 Rogelio Noriega 2001-03-29 16:43:08 UTC
For some reason bugzilla will not let me attach the file if any one needs the 
file please email me Rogelio_Noriega@dell.com

Comment 2 Glen Foster 2001-03-30 21:56:25 UTC
Created attachment 14303 [details]
dmesg file

Comment 3 Michael K. Johnson 2001-04-03 16:02:45 UTC
Doug, please investigate.  Is this a bug?

Comment 4 Mark Rusk 2001-04-06 18:22:53 UTC
This is probably not a bug, only a warning.  It is complaining abut this being a
version 0x20  IOAPIC.  This version should be added to the known types in
io_apic.c, but more needs to be know about the chipset being used.

Comment 5 Matt Domsch 2001-07-11 19:39:18 UTC
Kernel 2.4.5-10 lists the 0x20 ioapic.  Marking as "resolved rawhide".

Comment 6 Jim Wright 2002-06-25 05:10:14 UTC
In .../arch/i386/kernel/io_apic.c, using the 2.4.9-31 code as an example, the
following appears:


        printk(KERN_DEBUG ".......     : IO APIC version: %04X\n", reg_01.version);
        if (    (reg_01.version != 0x01) && /* 82489DX IO-APICs */
                (reg_01.version != 0x10) && /* oldest IO-APICs */
                (reg_01.version != 0x11) && /* Pentium/Pro IO-APICs */
                (reg_01.version != 0x13) && /* Xeon IO-APICs */
                (reg_01.entries != 0x20)    /* Intel P64H (82806 AA) */
        )
                UNEXPECTED_IO_APIC();

the last entry which adds support for type 0x20 is a typo.  this was caught and
fixed in the 2.4.14 Torvalds kernel.

I would like to see this bug fix backported to a kernel for 7.1/7.2.  is the
best option to reopen this bug report or to file a new one?  the kernel for 7.3
already has this fixed, obviously.

if an errata kernel for 7.1/7.2 will not be released in a timely manner, I'll
open a bug report which is not marked as beta-only that we can reference
customers to.  we have not seen any performance problems due to this, but if it
isn't fixed we at least need it documented.


Note You need to log in before you can comment on or make changes to this bug.