Bug 339161 - inline plotting of wxMaxima doesn't work in Fc7.
inline plotting of wxMaxima doesn't work in Fc7.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wxMaxima (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 00:11 EDT by Feng Yu
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7.2-4.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 17:20:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Feng Yu 2007-10-19 00:11:06 EDT
Description of problem:
inline plotting doesn't work.

Version-Release number of selected component (if applicable):
wxMaxima-0.7.2-2.fc7

How reproducible:
Always.

Steps to Reproduce:
1. from 'Plotting' menu, choose Plot 2d
2. input sin(x) in expressions
3. choose inline as format
4. click OK

  
Actual results:
One line of reply:
"Output file "/home/rainwoodman/maxout.png"."
and below it, 
a BIG X in a box.

Expected results:
the plotting of sin(x)

Additional info:
/home/rainwoodman/maxout.png doenot exist.
if I run 
$ gnuplot /home/rainwoodman/maxout.gnuplot
the output is
-------
gnuplot> set terminal png picsize 400 250; set zeroaxis;; 
                          ^
         "/home/rainwoodman/maxout.gnuplot", line 3: invalid color spec, must be
xRRGGBB
--------

It should be related to the old_gnuplot patch of wxMaxima.fc6 235155.

Reverting the patch should solve the problem.
Comment 1 Rex Dieter 2007-10-19 13:23:03 EDT
Yep,
edit 
/usr/share/wxMaxima/wxmathml.lisp
change
(defmvar $wxplot_old_gnuplot 1)
to
(defmvar $wxplot_old_gnuplot nil)
Comment 2 Rex Dieter 2007-11-01 09:07:30 EDT
%changelog
* Fri Oct 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.7.3-4.1
- inline plotting of wxMaxima doesn't work in f7 (#339161)
Comment 3 Rex Dieter 2007-11-01 09:19:11 EDT
Test build to try (an update is pending, coming soon):
http://koji.fedoraproject.org/koji/buildinfo?buildID=21679
Comment 4 Feng Yu 2007-11-01 10:04:20 EDT
The problem is solved in the test build. Thank you Rex!

Comment 5 Fedora Update System 2007-11-01 17:20:33 EDT
wxMaxima-0.7.2-4.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.