Bug 339261 - [5.2]virt-manager/virsh can't create virtual bridges
[5.2]virt-manager/virsh can't create virtual bridges
Status: CLOSED DUPLICATE of bug 251647
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.1
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 02:10 EDT by Tomohiro Takahashi
Modified: 2009-12-14 16:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-15 18:56:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomohiro Takahashi 2007-10-19 02:10:12 EDT
Description of problem:
virt-manager/virsh can't create virtual bridges

Version-Release number of selected component (if applicable):
libvirt-0.2.3-9.el5
libvirt-python-0.2.3-9.el5
python-virtinst-0.103.0-3.el5
libvirt-0.2.3-9.el5
virt-manager-0.4.0-3.el5

How reproducible:
always

Steps to Reproduce:
1.virt-manager/virsh doesn't have function to create virtual bridges
2.
3.
  
Actual results:
virt-manager/virsh can't create virtual bridges

Expected results:
virt-manager/virsh can create virtual bridges

Additional info:
Comment 1 Daniel Berrange 2007-10-19 07:55:12 EDT
There's not enough info in this ticket. Please explain what you mean by 'can't
create virtual bridges' ?  What commands are you running in virsh, and/or what
UI are you using in virt-manager. Details of any error messages too & the
virt-manager log file from /root/.virt-manager/virt-manager.log
Comment 2 Tomohiro Takahashi 2007-11-13 07:06:14 EST
Hi,

> There's not enough info in this ticket. 
> Please explain what you mean by 'can't create virtual bridges' ?  

I think that virsh/virt-manager can create virtual bridges
(xenbr,virbr,vnet,etc.),
because virsh/virt-manager doesn't have function to create virtual bridges and 
there is the following problems when creating virtual bridges with the script. 
1) It is necessary to use scripts properly.
   ex) /etc/xen/scripts/network-bridge
       /etc/xen/scripts/vir-bridge
       /etc/xen/scripts/vif-nat
2) virtual bridges cannot be modified.

I think about the following. 
[create]
- dialogue mode
 # virt-bridge [RETURN]
 Do you want to create virtual network bridge ?  [yes/no]  yes [RETURN]
 The following virtual network bridge have been defined; 
    - NAT network
      o virbr0 on private 192.168.20.0.
    - Bridged network
      o xenbr0 is bridged to eth0
    - Internal network
      o vnet0 on private 192.168.30.0.

 What type of virtual network bridges?  [bridge/NAT/internal/none] internal 
[RETUNRN]

 What number is network bridge?

- option mode
 # virt-bridge create --type=bridge --num=0 --to=eth0
 # virt-bridge create --type=nat --num=0
 # virt-bridge create --type=internal --num=0

[modify]
- dialogue mode
 Do you want to make any changes to the current bridges? [yes/no] yes [RETURN]
 Which do you want to change to the bridges? [virbr0/xenbr0/new] new [RETURN]
      o virbr0 on private 192.168.20.0.
      o xenbr0 is bridged to eth0

- option mode
 # virt-bridge change virbr0 --type=...

> What commands are you running in virsh, and/or what UI are you using in virt-
manager.
 
 I cannot use virsh/virt-manage, because virsh/virt-manager doesn't have 
function to create virtual bridges

> Details of any error messages too & the virt-manager log file 
from /root/.virt-manager/virt-manager.log

There aren't messages and log.

Thanks,
Tomohiro Takahashi.
Comment 3 Daniel Berrange 2007-11-13 09:03:29 EST
There is already the ability to create a NAT  based network, and an 'internal'
isolated network in both virsh and virt-manager. See the 'net-*' commands in
virsh, and in virt-manager  'Edit -> Host details -> Networking'.

The primary capability that is not present is the ability to create a true
bridge attached to a physical device. For the the latter, we recommend using
either the Xen network-bridge script, or the regular distro scripts in
/etc/sysconfig/networking-scripts/

Comment 4 Cole Robinson 2009-02-15 18:56:25 EST

*** This bug has been marked as a duplicate of bug 251647 ***

Note You need to log in before you can comment on or make changes to this bug.