Bug 339621 - XFS lazy vunmap behaviour is incompatible with xen
Summary: XFS lazy vunmap behaviour is incompatible with xen
Status: CLOSED DUPLICATE of bug 470845
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Eric Sandeen
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 492570
TreeView+ depends on / blocked
 
Reported: 2007-10-19 12:10 UTC by Ian Campbell
Modified: 2009-03-27 14:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 13:37:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
linux-2.6.18-xen 263:9bf1ddd0f6bf ported to 2.6.9-67.EL (2.04 KB, patch)
2007-12-14 09:20 UTC, Ian Campbell
no flags Details | Diff
linux-2.6.18-xen 263:9bf1ddd0f6bf ported to 2.6.18-53.el5 (2.04 KB, patch)
2007-12-14 09:21 UTC, Ian Campbell
no flags Details | Diff

Description Ian Campbell 2007-10-19 12:10:57 UTC
Description of problem:

XFS lazily vunmaps, if one of those pages is recylced into a pagetable page
before it is fully unmapped then the extra writable mapping causes the pagetable
to be rejected.

LKML thread: http://marc.info/?l=linux-kernel&m=119220904017315&w=2
Fix in upstream GIT commit 7f015072348a14f16d548be557ee58c5c55df0aa:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=7f015072348a14f16d548be557ee58c5c55df0aa

Also in Xen kernel tree:
http://hg.uk.xensource.com/linux-2.6.18-xen.hg?cs=9bf1ddd0f6bf


Version-Release number of selected component (if applicable):
2.6.18-8.1.14.el5 and 2.6.9-55.0.9.EL

Comment 1 Ian Campbell 2007-12-14 09:20:48 UTC
Created attachment 288831 [details]
linux-2.6.18-xen 263:9bf1ddd0f6bf ported to 2.6.9-67.EL

Comment 2 Ian Campbell 2007-12-14 09:21:28 UTC
Created attachment 288841 [details]
linux-2.6.18-xen 263:9bf1ddd0f6bf ported to 2.6.18-53.el5

Comment 7 Chris Lalancette 2009-03-26 13:37:07 UTC

*** This bug has been marked as a duplicate of bug 470845 ***


Note You need to log in before you can comment on or make changes to this bug.