Bug 339781 - broken zoneinfo for certain timezones
broken zoneinfo for certain timezones
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 10:38 EDT by Mohd Izhar Firdaus Ismail
Modified: 2015-05-04 21:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-09 07:34:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohd Izhar Firdaus Ismail 2007-10-19 10:38:59 EDT
Description of problem:
wrong time & timezone details for certain timezones 

3 of which i noticed
Asia/Kuala_Lumpur & Asia/Singapore - late 30 minutes than the actual time
Asia/Kuala_Lumpur & Asia/Kuching - wrong timezone abbr

Version-Release number of selected component (if applicable):
tzdata-2007h-1.fc8

How reproducible:
Everytime

Steps to Reproduce:
1. Switch to the above timezones
2. date
3.
  
Actual results:
[root@Hikari etc]# TZ=UTC date 
Fri Oct 19 14:35:39 UTC 2007
[root@Hikari etc]# TZ=Asia/Kuala_Lumpur date 
Fri Oct 19 22:05:40 MALT 2007
[root@Hikari etc]# TZ=Asia/Kuching date 
Fri Oct 19 22:35:45 BORT 2007
[root@Hikari etc]# TZ=Asia/Singapore date 
Fri Oct 19 22:05:51 SGT 2007


Expected results:
[root@Hikari etc]# TZ=UTC date 
Fri Oct 19 14:35:39 UTC 2007
[root@Hikari etc]# TZ=Asia/Kuala_Lumpur date 
Fri Oct 19 22:35:40 MYT 2007
[root@Hikari etc]# TZ=Asia/Kuching date 
Fri Oct 19 22:35:45 MYT 2007
[root@Hikari etc]# TZ=Asia/Singapore date 
Fri Oct 19 22:35:51 SGT 2007


Additional info:

rpm -V is silent

there might be other affected zoneinfos too
Comment 1 Petr Machata 2007-10-29 15:00:45 EDT
Did it change recently? I.e., did tzdata used to report correct abbreviations
and zones, and suddenly it stopped working, or did you only discovered it
recently and don't really know when did it get broken?

There's another bug opened with symptoms similar to yours, and I suspect the
problem is not in tzdata, but in one of the components that take part in
updating the OS.  I've tried a few installations, and tzdata reports correct
values on all of them.

Also, would you please issue following commands, and copy here their output? 

ls -ls /usr/share/zoneinfo/{America/Chicago,Asia/Kuala_Lumpur}
sha1sum /usr/share/zoneinfo/{America/Chicago,Asia/Kuala_Lumpur}
/usr/sbin/zdump -v /usr/share/zoneinfo/America/Chicago | grep 2007

(Chicago was selected to match the other bug report.  I know that rpm -V check
md5, I just want to see whether the checksums really match, and the dates are
still reported wrongly between our two installations.  If they don't match,
well, then it's question why -V doesn't yell on at least one of our boxes.)
Comment 2 Mohd Izhar Firdaus Ismail 2007-10-30 09:56:33 EDT
I just switched back to Kuala_Lumpur from another tz which also on GMT+8, seems
like the problem is no longer there .. 

guess ure right about it might be caused by something else of which i have no
idea what it is..

Note You need to log in before you can comment on or make changes to this bug.