Bug 340061 - eclipse-cdt broken/dead/gone
eclipse-cdt broken/dead/gone
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 13:10 EDT by cje
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-20 02:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cje 2007-10-19 13:10:18 EDT
Description of problem:
various specific symptoms after much uninstalling and reinstalling but the gist
is that eclipse-cdt doesn't work anymore.
first eclipse started hanging on startup with the splash screen up.
then (after some uninstall-reinstall) i got an error on startup:
   Failed to load Main-Class manifest attribute from startup.jar
also a pop-up window with errors.  this could have been a pirut/yum problem.
uninstall-reinstall some more.
now the IDE will run but appears to have forgotten all about C/C++ stuff.
help->software updates->manage configuration produces no window.
window->open perspective->other... shows no C/C++ stuff.
window->preferences doesn't have a C/C++ section.
reverting to the previous version of eclipse-cdt didn't fix it.  in fact i think
i just got the java error trying to run it again.
moving to the version in rawhide sorted everything out. (yum remove ant; yum
--enablerepo=development install eclipse-cdt)

Version-Release number of selected component (if applicable):
3.1.2-8.fc7
Comment 1 cje 2007-10-19 17:01:47 EDT
ah.  more problems.  turns out that moving to the rawhide version solves the
startup error but doesn't recover the CDT environment.

i've just installed eclipse-cdt (and 33 dependencies) from rawhide and i can
start eclipse okay but i still don't have a CDT perspective and the 'manage
configuration' option still produces no window.

i've tried moving my workspaces and my .eclipse folders but still no luck.
Comment 2 Jeff Johnston 2007-10-19 19:07:19 EDT
I'm going to need more information.  What platform are you running?

Can you tell me what rpm -qa | grep eclipse and rpm -qa | grep java gives you?

FWIW: I am seeing no problem on an x86 32-bit laptop running F7 with
eclipse-cdt-3.1.2-8.fc7 installed.  I am using gcj.  I specified a clean
workspace and was able to create a Managed Make hello world program without a hitch.

Are you using an external jdk or defaulting to use gcj?  Any log messages produced?
Comment 3 cje 2007-10-20 02:35:58 EDT
okay.  thanks for responding.  it looks like i've got it working again now.  i
was one stop away from re-installing the OS!

checking through the log below i see it's possible that making a clean home
folder (from /etc/skel) is what really got it working again.  maybe.  not sure
that there's anything in there that's relevant other than .eclipse and
workspaces (which i'd already tried removing.)

also possibly relevant, recently (last month or so) eclipse had been failing to
start (getting stuck on the splash screen) particularly when started from
gimmie.  i had to 'killall eclipse' and then kill off the launcher in order to
be able to try running it from the command line.  that had been working up until
 this bug.  could it be that killing the stuck launcher damaged some config files?

for completeness:

i'm on x86_64.  IIRC this system was installed as FC6 and then upgraded from the
F7 dvd.  then kept up to date with yum.  it includes livna for nvidia and
mplayer/dvds and adobe for flash.  no non-fedora java stuff i think.

after the upgrade from FC6 i had lots of problems with left-over FC6 packages
and the biggest problems were with java/eclipse.  the solution to most of those
problems was to force rpm to remove the FC6 packages and then let yum re-install
the F7 ones (with the same version number).

essentially that's what i've just done again.  i did the rpm -qa for eclipse and
java and had endless fun trying to remove all the results.  i got a lot of
errors depending on the order they were removed.

i've still got a lot of things which claim to be FC6, Extras, None or Unknown. 
but i can't tell if they're relevant or mis-labelled or what.

for your amusement, here's the *annotated* contents of /var/log/yum.log since
eclipse started going wrong until now:

*eclipse gone wrong - reinstall CDT*
Oct 18 20:41:37 Erased: eclipse-cdt
Oct 18 20:44:10 Installed: eclipse-cdt.x86_64 3.1.2-8.fc7
*still broken - try re-install eclipse*
Oct 18 20:59:18 Erased: eclipse-phpeclipse
Oct 18 20:59:21 Erased: eclipse-mylar
Oct 18 20:59:22 Erased: eclipse-sdk-nls-ja
Oct 18 20:59:23 Erased: eclipse-ecj
Oct 18 20:59:25 Erased: eclipse-checkstyle
Oct 18 20:59:27 Erased: eclipse-changelog
Oct 18 20:59:28 Erased: eclipse-jdt
Oct 18 20:59:30 Erased: eclipse-rcp
Oct 18 20:59:31 Erased: eclipse-pde-runtime
Oct 18 20:59:32 Erased: eclipse-pydev
Oct 18 20:59:34 Erased: eclipse-mylar-bugzilla
Oct 18 21:07:16 Erased: eclipse-platform
Oct 18 21:07:21 Erased: eclipse-cdt
Oct 18 21:16:19 Installed: eclipse-platform.x86_64 3.2.2-15.fc7
Oct 18 21:16:21 Installed: eclipse-ecj.x86_64 3.2.2-15.fc7
Oct 18 21:16:24 Installed: eclipse-cdt.x86_64 3.1.2-8.fc7
Oct 18 21:16:24 Installed: eclipse-changelog.x86_64 2.3.4-1.fc7
Oct 18 21:16:28 Installed: eclipse-jdt.x86_64 3.2.2-15.fc7
Oct 19 01:22:54 Installed: eclipse-mylar - 2.0-0.1.M2a.1.fc7.x86_64
Oct 19 01:22:56 Installed: eclipse-pde-runtime - 1:3.2.2-15.fc7.x86_64
Oct 19 01:22:59 Installed: eclipse-rcp - 1:3.2.2-15.fc7.x86_64
Oct 19 01:23:01 Installed: eclipse-sdk-nls-ja - 3.2.1-3.fc7.noarch
Oct 19 01:23:04 Installed: eclipse-phpeclipse - 1.1.8-16.fc7.x86_64
Oct 19 01:23:09 Installed: eclipse-pydev - 1:1.3.1-5.fc7.x86_64
Oct 19 01:23:10 Installed: eclipse-mylar-bugzilla - 2.0-0.1.M2a.1.fc7.x86_64
Oct 19 01:23:12 Installed: eclipse-checkstyle - 4.0.1-6.fc7.x86_64
*still broken.  try reinstall eclipse and ant*
Oct 19 01:29:17 Erased: eclipse-phpeclipse
Oct 19 01:29:19 Erased: ant-commons-logging
Oct 19 01:29:19 Erased: ant-apache-regexp
Oct 19 01:29:20 Erased: ant-antlr
Oct 19 01:29:21 Erased: ant-apache-oro
Oct 19 01:29:22 Erased: ant-apache-log4j
Oct 19 01:29:23 Erased: ant-nodeps
Oct 19 01:29:24 Erased: ant-apache-bcel
Oct 19 01:29:25 Erased: eclipse-checkstyle
Oct 19 01:29:26 Erased: ant-jsch
Oct 19 01:29:28 Erased: eclipse-platform
Oct 19 01:29:32 Erased: checkstyle
Oct 19 01:29:33 Erased: eclipse-cdt
Oct 19 01:29:34 Erased: ant-junit
Oct 19 01:29:35 Erased: ant-jdepend
Oct 19 01:29:36 Erased: eclipse-changelog
Oct 19 01:29:37 Erased: eclipse-jdt
Oct 19 01:29:38 Erased: eclipse-pde-runtime
Oct 19 01:29:39 Erased: ant
Oct 19 01:29:40 Erased: ant-apache-resolver
Oct 19 01:29:41 Erased: ant-swing
Oct 19 01:29:41 Erased: checkstyle-optional
Oct 19 01:29:42 Erased: eclipse-mylar
Oct 19 01:29:42 Erased: eclipse-pydev
Oct 19 01:29:44 Erased: eclipse-mylar-bugzilla
Oct 19 01:29:44 Erased: ant-trax
Oct 19 01:29:45 Erased: ant-javamail
Oct 19 01:32:48 Installed: ant - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:49 Installed: ant-antlr - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:50 Installed: ant-nodeps - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:51 Installed: ant-jsch - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:52 Installed: ant-apache-resolver - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:52 Installed: ant-swing - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:53 Installed: ant-apache-regexp - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:54 Installed: ant-apache-oro - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:55 Installed: ant-javamail - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:56 Installed: ant-apache-log4j - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:56 Installed: ant-commons-logging - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:57 Installed: ant-jdepend - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:58 Installed: ant-trax - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:32:59 Installed: ant-apache-bcel - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:33:00 Installed: ant-junit - 1.6.5-4jpp.2.fc7.x86_64
Oct 19 01:33:05 Installed: eclipse-platform - 1:3.2.2-15.fc7.x86_64
Oct 19 01:33:08 Installed: eclipse-cdt - 1:3.1.2-8.fc7.x86_64
*no good.  just erase some stuff.*
Oct 19 01:57:49 Erased: ant-antlr
Oct 19 01:57:50 Erased: ant-nodeps
Oct 19 01:57:51 Erased: ant
Oct 19 01:57:52 Erased: ant-apache-log4j
Oct 19 01:57:53 Erased: ant-apache-resolver
Oct 19 01:57:54 Erased: ant-swing
Oct 19 01:57:54 Erased: ant-apache-regexp
Oct 19 01:57:55 Erased: ant-jsch
Oct 19 01:57:57 Erased: eclipse-cdt
Oct 19 01:57:58 Erased: ant-javamail
Oct 19 01:58:00 Erased: eclipse-platform
Oct 19 01:58:03 Erased: ant-apache-oro
Oct 19 01:58:03 Erased: ant-commons-logging
Oct 19 01:58:04 Erased: ant-jdepend
Oct 19 01:58:05 Erased: ant-trax
Oct 19 01:58:05 Erased: ant-apache-bcel
Oct 19 01:58:06 Erased: ant-junit
*give up.  try rawhide version...*
Oct 19 21:48:55 Installed: ant - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:48:56 Updated: tomcat5-servlet-2.4-api - 5.5.23-9jpp.4.fc8.x86_64
Oct 19 21:48:57 Updated: jakarta-commons-el - 1.0-8jpp.2.fc8.x86_64
Oct 19 21:48:58 Updated: tomcat5-jasper - 5.5.23-9jpp.4.fc8.x86_64
Oct 19 21:48:59 Updated: tomcat5-jsp-2.0-api - 5.5.23-9jpp.4.fc8.x86_64
Oct 19 21:49:00 Updated: jakarta-commons-logging - 1.0.4-6jpp.4.fc8.x86_64
Oct 19 21:49:01 Updated: lucene - 1.9.1-1jpp.5.fc8.x86_64
Oct 19 21:49:02 Updated: libswt3-gtk2 - 1:3.3.0-27.fc8.x86_64
Oct 19 21:49:03 Updated: jsch - 0.1.31-1jpp.2.fc8.x86_64
Oct 19 21:49:04 Installed: ant-jsch - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:05 Installed: lucene-contrib - 1.9.1-1jpp.5.fc8.x86_64
Oct 19 21:49:08 Installed: jetty - 5.1.12-1jpp.7.fc8.x86_64
Oct 19 21:49:09 Installed: ant-commons-logging - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:10 Updated: tomcat5-common-lib - 5.5.23-9jpp.4.fc8.x86_64
Oct 19 21:49:12 Updated: tomcat5-server-lib - 5.5.23-9jpp.4.fc8.x86_64
Oct 19 21:49:16 Updated: tomcat5 - 5.5.23-9jpp.4.fc8.x86_64
Oct 19 21:49:16 Installed: ant-swing - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:17 Installed: ant-apache-oro - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:19 Installed: ant-javamail - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:20 Installed: ant-junit - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:20 Installed: ant-apache-resolver - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:21 Installed: ant-apache-regexp - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:22 Installed: ant-apache-bcel - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:23 Installed: ant-trax - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:24 Installed: ant-antlr - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:26 Installed: ant-jdepend - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:26 Installed: ant-apache-log4j - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:27 Installed: ant-nodeps - 1.7.0-1jpp.2.fc8.x86_64
Oct 19 21:49:28 Installed: tomcat5-jasper-eclipse - 5.5.23-9jpp.4.fc8.x86_64
Oct 19 21:49:29 Installed: icu4j-eclipse - 3.6.1-1jpp.3.fc8.x86_64
Oct 19 21:49:32 Updated: eclipse-rcp - 1:3.3.0-27.fc8.x86_64
Oct 19 21:49:33 Installed: eclipse-cvs-client - 1:3.3.0-27.fc8.x86_64
Oct 19 21:49:40 Installed: eclipse-platform - 1:3.3.0-27.fc8.x86_64
Oct 19 21:49:45 Installed: eclipse-cdt - 1:4.0.1-1.fc8.x86_64
Oct 19 21:49:51 Erased: lucene-devel
*turns out that doesn't work either - meanwhile, system updates!*
Oct 20 05:25:04 Updated: pango.x86_64 1.16.4-2.fc7
Oct 20 05:25:07 Updated: openssl.i686 0.9.8b-15.fc7
Oct 20 05:25:11 Updated: openssl.x86_64 0.9.8b-15.fc7
Oct 20 05:25:17 Updated: libvirt.x86_64 0.3.3-1.fc7
Oct 20 05:25:19 Updated: pango.i386 1.16.4-2.fc7
Oct 20 05:25:23 Updated: vte.x86_64 0.16.9-1.fc7
Oct 20 05:25:26 Installed: timidity++-patches.x86_64 2.13.2-4.fc7
Oct 20 05:25:26 Updated: fedora-usermgmt-default-fedora-setup.noarch 0.10-1.fc7
Oct 20 05:25:28 Updated: timidity++.x86_64 2.13.2-4.fc7
Oct 20 05:25:30 Updated: pango-devel.i386 1.16.4-2.fc7
Oct 20 05:25:30 Updated: libvirt-python.x86_64 0.3.3-1.fc7
Oct 20 05:25:33 Updated: openssl-devel.x86_64 0.9.8b-15.fc7
Oct 20 05:25:35 Updated: openssl-devel.i386 0.9.8b-15.fc7
Oct 20 05:25:37 Updated: pango-devel.x86_64 1.16.4-2.fc7
Oct 20 05:25:39 Updated: hotwire.noarch 0.599-1.fc7
Oct 20 05:25:41 Updated: gnome-theme-clearlooks-bigpack.noarch 0.6-6.fc7
Oct 20 05:25:43 Updated: gdb.x86_64 6.6-16.fc7
Oct 20 05:25:44 Updated: vorbis-tools.x86_64 1.1.1.svn20070412-3.fc7
Oct 20 05:25:44 Updated: fedora-usermgmt-core.noarch 0.10-1.fc7
Oct 20 05:25:44 Updated: fedora-usermgmt-shadow-utils.noarch 0.10-1.fc7
Oct 20 05:25:44 Updated: fedora-usermgmt.noarch 0.10-1.fc7
*okay.  since we're going to re-install, let's have one last super-aggressive
re-install effort .. eclipse, ant, java etc*
Oct 20 05:31:50 Erased: jetty
Oct 20 05:31:54 Erased: java-1.5.0-gcj-devel
Oct 20 05:31:54 Erased: ant-trax
Oct 20 05:31:55 Erased: ant-junit
Oct 20 05:31:57 Erased: eclipse-cdt
Oct 20 05:31:58 Erased: ant-jsch
Oct 20 05:31:59 Erased: ant
Oct 20 05:32:00 Erased: eclipse-platform
Oct 20 05:32:03 Erased: ant-swing
Oct 20 05:32:03 Erased: ant-javamail
Oct 20 05:32:04 Erased: ant-commons-logging
Oct 20 05:32:05 Erased: gcc-java
Oct 20 05:32:05 Erased: ant-apache-oro
Oct 20 05:32:06 Erased: ant-apache-regexp
Oct 20 05:32:07 Erased: tomcat5
Oct 20 05:32:08 Erased: ant-antlr
Oct 20 05:32:09 Erased: ant-nodeps
Oct 20 05:32:09 Erased: ant-apache-bcel
Oct 20 05:32:10 Erased: ant-apache-log4j
Oct 20 05:32:11 Erased: ant-apache-resolver
Oct 20 05:32:11 Erased: ant-jdepend
Oct 20 05:32:32 Erased: jakarta-commons-collections-tomcat5
Oct 20 05:32:33 Erased: mysql-connector-java
Oct 20 05:32:33 Erased: jsch
Oct 20 05:32:34 Erased: bsf
Oct 20 05:32:35 Erased: jakarta-commons-dbcp
Oct 20 05:32:35 Erased: libreadline-java
Oct 20 05:32:36 Erased: tomcat5-jasper
Oct 20 05:32:37 Erased: openoffice.org-writer
Oct 20 05:32:38 Erased: libswt3-gtk2
Oct 20 05:32:39 Erased: jakarta-commons-collections
Oct 20 05:32:40 Erased: openoffice.org-draw
Oct 20 05:32:41 Erased: openoffice.org-base
Oct 20 05:32:42 Erased: tomcat5-jasper-eclipse
Oct 20 05:32:43 Erased: eclipse-sdk-nls-ja
Oct 20 05:32:44 Erased: axis
Oct 20 05:32:44 Erased: velocity
Oct 20 05:32:45 Erased: classpathx-mail
Oct 20 05:32:46 Erased: jython
Oct 20 05:32:47 Erased: avalon-logkit
Oct 20 05:32:48 Erased: java-1.5.0-gcj
Oct 20 05:32:49 Erased: classpathx-jaf
Oct 20 05:32:49 Erased: sinjdoc
Oct 20 05:32:50 Erased: java_cup
Oct 20 05:32:50 Erased: jakarta-commons-logging
Oct 20 05:32:50 Erased: eclipse-cvs-client
Oct 20 05:32:50 Erased: tomcat5-jsp-2.0-api
Oct 20 05:32:51 Erased: jakarta-commons-el
Oct 20 05:32:54 Erased: openoffice.org-core
Oct 20 05:32:57 Erased: bsh
Oct 20 05:32:58 Erased: jakarta-commons-fileupload
Oct 20 05:32:58 Erased: junit
Oct 20 05:32:58 Erased: ws-commons-util
Oct 20 05:32:58 Erased: werken-xpath
Oct 20 05:32:58 Erased: eclipse-ecj
Oct 20 05:32:58 Erased: hsqldb
Oct 20 05:32:59 Erased: jakarta-commons-beanutils
Oct 20 05:32:59 Erased: xml-commons-apis
Oct 20 05:32:59 Erased: jakarta-commons-cli
Oct 20 05:33:00 Erased: jakarta-oro
Oct 20 05:33:00 Erased: antlr
Oct 20 05:33:00 Erased: wsdl4j
Oct 20 05:33:01 Erased: jakarta-commons-httpclient
Oct 20 05:33:01 Erased: openoffice.org-math
Oct 20 05:33:02 Erased: jdom
Oct 20 05:33:03 Erased: tomcat5-server-lib
Oct 20 05:33:03 Erased: log4j
Oct 20 05:33:03 Erased: tomcat5-common-lib
Oct 20 05:33:05 Erased: java-1.5.0-gcj-javadoc
Oct 20 05:33:07 Erased: eclipse-rcp
Oct 20 05:33:07 Erased: jakarta-commons-lang
Oct 20 05:33:08 Erased: avalon-framework
Oct 20 05:33:08 Erased: tomcat5-servlet-2.4-api
Oct 20 05:33:08 Erased: jakarta-commons-discovery
Oct 20 05:33:08 Erased: jakarta-commons-codec
Oct 20 05:33:08 Erased: xerces-j2
Oct 20 05:33:09 Erased: lucene
Oct 20 05:33:09 Erased: geronimo-specs
Oct 20 05:33:09 Erased: geronimo-specs-compat
Oct 20 05:33:09 Erased: jdepend
Oct 20 05:33:09 Erased: jakarta-commons-modeler
Oct 20 05:33:10 Erased: jakarta-commons-pool
Oct 20 05:33:10 Erased: jzlib
Oct 20 05:33:10 Erased: bcel
Oct 20 05:33:10 Erased: regexp
Oct 20 05:33:11 Erased: jakarta-commons-launcher
Oct 20 05:33:11 Erased: mx4j
Oct 20 05:33:12 Erased: jakarta-commons-daemon
Oct 20 05:33:12 Erased: openoffice.org-calc
Oct 20 05:33:13 Erased: lucene-contrib
Oct 20 05:33:14 Erased: xalan-j2
Oct 20 05:33:14 Erased: xml-commons-resolver
Oct 20 05:33:14 Erased: openoffice.org-impress
Oct 20 05:33:15 Erased: jakarta-commons-dbcp-tomcat5
Oct 20 05:33:16 Erased: jakarta-commons-digester
Oct 20 05:33:17 Erased: saxon
*got some script errors.  try leftovers again*
Oct 20 05:45:19 Erased: icu4j-eclipse
Oct 20 05:45:20 Erased: tomcat5-common-lib
Oct 20 05:45:20 Erased: eclipse-ecj
Oct 20 05:45:20 Erased: eclipse-rcp
*and again*
Oct 20 05:46:03 Erased: lucene
Oct 20 05:46:30 Erased: tomcat5-common-lib
*check dependencies and add stuff back in to make the scripts work*
Oct 20 05:50:19 Installed: java-1.5.0-gcj - 1.5.0.0-14.fc7.x86_64
Oct 20 05:50:20 Installed: sinjdoc - 0.5-4.fc7.x86_64
Oct 20 05:50:21 Installed: java_cup - 1:0.10-0.k.6jpp.1.x86_64
*now just erase those bits*
Oct 20 05:51:26 Erased: tomcat5-servlet-2.4-api
Oct 20 05:51:27 Erased: tomcat5-common-lib
Oct 20 05:51:27 Erased: tomcat5-jsp-2.0-api
Oct 20 05:51:27 Erased: geronimo-specs
Oct 20 05:51:28 Erased: tomcat5-server-lib
*try the others again*
Oct 20 05:54:42 Erased: lucene
Oct 20 05:54:43 Erased: eclipse-rcp
*trying to remove jakarta and FC6 things*
Oct 20 05:55:56 Erased: gedit
Oct 20 05:56:03 Erased: jakarta-commons-cli
Oct 20 05:56:03 Erased: libsexy
Oct 20 05:56:22 Erased: abiword
Oct 20 05:56:24 Erased: enchant
Oct 20 05:56:25 Erased: python-sexy
Oct 20 05:56:28 Erased: gimmie
Oct 20 05:58:38 Installed: enchant - 1:1.3.0-1.fc6.x86_64
Oct 20 05:58:38 Installed: libsexy - 0.1.11-1.fc7.x86_64
Oct 20 05:58:39 Installed: python-sexy - 0.1.9-3.fc7.x86_64
Oct 20 05:58:47 Installed: gedit - 1:2.18.2-1.fc7.x86_64
Oct 20 05:58:50 Installed: abiword - 1:2.4.6-5.fc7.x86_64
Oct 20 05:58:52 Installed: gimmie - 0.2.7-1.fc7.x86_64
*ah well.  not to worry.  back to re-removing java*
Oct 20 06:01:17 Erased: java-1.5.0-gcj
Oct 20 06:01:17 Erased: sinjdoc
Oct 20 06:01:18 Erased: java_cup
Oct 20 06:01:18 Erased: eclipse-ecj
Oct 20 06:01:18 Erased: ws-commons-util
Oct 20 06:02:33 Erased: jakarta-commons-beanutils-javadoc
Oct 20 06:03:49 Erased: xml-commons-apis-javadoc
Oct 20 06:03:50 Erased: libgnome-java
Oct 20 06:03:50 Erased: libgconf-java
Oct 20 06:03:51 Erased: libvte-java
Oct 20 06:03:51 Erased: frysk
Oct 20 06:03:52 Erased: antlr-javadoc
Oct 20 06:03:53 Erased: cairo-java
Oct 20 06:03:54 Erased: frysk-gnome
Oct 20 06:03:56 Erased: ant-javadoc
Oct 20 06:03:57 Erased: libglade-java
Oct 20 06:03:58 Erased: glib-java
Oct 20 06:03:58 Erased: libgtk-java
Oct 20 06:37:53 Erased: jakarta-commons-pool-tomcat5
Oct 20 06:37:54 Erased: eclipse-ecj
Oct 20 06:41:23 Erased: eclipse-ecj
Oct 20 06:41:41 Erased: eclipse-ecj
*lots more script problems.  do the 'put things back' trick again*
Oct 20 06:43:54 Installed: java-1.5.0-gcj - 1.5.0.0-14.fc7.x86_64
Oct 20 06:43:55 Installed: sinjdoc - 0.5-4.fc7.x86_64
Oct 20 06:43:56 Installed: java_cup - 1:0.10-0.k.6jpp.1.x86_64
Oct 20 06:44:10 Erased: eclipse-ecj
Oct 20 06:44:52 Erased: java-1.5.0-gcj
Oct 20 06:44:53 Erased: sinjdoc
Oct 20 06:44:53 Erased: java_cup
Oct 20 06:44:53 Erased: ws-commons-util
*once more for luck*
Oct 20 06:45:46 Installed: java-1.5.0-gcj - 1.5.0.0-14.fc7.x86_64
Oct 20 06:45:48 Installed: sinjdoc - 0.5-4.fc7.x86_64
Oct 20 06:45:48 Installed: java_cup - 1:0.10-0.k.6jpp.1.x86_64
Oct 20 06:46:05 Erased: ws-commons-util
Oct 20 06:46:19 Erased: java-1.5.0-gcj
Oct 20 06:46:19 Erased: sinjdoc
Oct 20 06:46:20 Erased: java_cup
*yes!  it's all gone.  many reboots and a clean home folder and very default
package selections in pirut just to be safest...*
Oct 20 06:58:57 Installed: jakarta-commons-pool-tomcat5.x86_64 1.3-9jpp.2.fc7.1
Oct 20 06:59:00 Installed: java-1.5.0-gcj.x86_64 1.5.0.0-14.fc7
Oct 20 06:59:01 Installed: jakarta-commons-logging.x86_64 1.0.4-6jpp.1
Oct 20 06:59:01 Installed: xml-commons-apis.x86_64 1.3.03-0jpp.1.fc7
Oct 20 06:59:02 Installed: tomcat5-servlet-2.4-api.x86_64 5.5.23-9jpp.2.fc7
Oct 20 06:59:03 Installed: jakarta-commons-collections.x86_64 3.1-9jpp.2.fc7.1
Oct 20 06:59:04 Installed: eclipse-ecj.x86_64 3.2.2-15.fc7
Oct 20 06:59:04 Installed: classpathx-jaf.x86_64 1.0-9jpp.1
Oct 20 06:59:05 Installed: classpathx-mail.x86_64 1.1.1-4jpp.3
Oct 20 06:59:06 Installed: jakarta-commons-beanutils.x86_64 1.7.0-5jpp.1
Oct 20 06:59:07 Installed: tomcat5-jasper.x86_64 5.5.23-9jpp.2.fc7
Oct 20 06:59:08 Installed: xml-commons-resolver.x86_64 1.1-1jpp.12
Oct 20 06:59:09 Installed: log4j.x86_64 1.2.13-3jpp.2
Oct 20 06:59:10 Installed: regexp.x86_64 1.4-3jpp.1.fc7
Oct 20 06:59:10 Installed: bcel.x86_64 5.1-10jpp.4.fc7
Oct 20 06:59:11 Installed: xerces-j2.x86_64 2.7.1-7jpp.2
Oct 20 06:59:12 Installed: jakarta-commons-digester.x86_64 1.7-6jpp.1
Oct 20 06:59:13 Installed: jakarta-commons-collections-tomcat5.x86_64
3.1-9jpp.2.fc7.1
Oct 20 06:59:13 Installed: jakarta-commons-launcher.x86_64 1.1-1jpp.2.fc7
Oct 20 06:59:14 Installed: jakarta-commons-dbcp-tomcat5.x86_64 1.2.1-10jpp.1.fc7
Oct 20 06:59:15 Installed: junit.x86_64 3.8.2-3jpp.1.fc7
Oct 20 06:59:15 Installed: jakarta-commons-el.x86_64 1.0-7jpp.1.fc7
Oct 20 06:59:16 Installed: lucene.x86_64 1.4.3-1jpp.18
Oct 20 06:59:17 Installed: libswt3-gtk2.x86_64 3.2.2-15.fc7
Oct 20 06:59:18 Installed: jakarta-commons-pool.x86_64 1.3-9jpp.2.fc7.1
Oct 20 06:59:19 Installed: xalan-j2.x86_64 2.7.0-6jpp.1
Oct 20 06:59:20 Installed: jakarta-commons-dbcp.x86_64 1.2.1-10jpp.1.fc7
Oct 20 06:59:23 Installed: eclipse-rcp.x86_64 3.2.2-15.fc7
Oct 20 06:59:23 Installed: lucene-devel.x86_64 1.4.3-1jpp.18
Oct 20 06:59:25 Installed: gcc-java.x86_64 4.1.2-27.fc7
Oct 20 06:59:25 Installed: java-1.5.0-gcj-devel.x86_64 1.5.0.0-14.fc7
Oct 20 06:59:26 Installed: ant.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:27 Installed: ant-commons-logging.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:27 Installed: ant-apache-regexp.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:28 Installed: ant-nodeps.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:29 Installed: ant-apache-log4j.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:29 Installed: ant-apache-bcel.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:30 Installed: ant-javamail.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:30 Installed: ant-apache-resolver.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:31 Installed: ant-swing.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:32 Installed: ant-trax.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:32 Installed: ant-junit.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:33 Installed: tomcat5-jsp-2.0-api.x86_64 5.5.23-9jpp.2.fc7
Oct 20 06:59:34 Installed: tomcat5-common-lib.x86_64 5.5.23-9jpp.2.fc7
Oct 20 06:59:35 Installed: jakarta-commons-fileupload.x86_64 1.0-6jpp.1
Oct 20 06:59:35 Installed: jakarta-commons-httpclient.x86_64 3.0.1-1jpp.1.fc7
Oct 20 06:59:36 Installed: jakarta-commons-discovery.x86_64 0.3-4jpp.1
Oct 20 06:59:37 Installed: jakarta-oro.x86_64 2.0.8-3jpp.1
Oct 20 06:59:38 Installed: ant-apache-oro.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:39 Installed: antlr.x86_64 2.7.7-1jpp.3.fc7.2
Oct 20 06:59:40 Installed: ant-antlr.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:41 Installed: sinjdoc.x86_64 0.5-4.fc7
Oct 20 06:59:41 Installed: java_cup.x86_64 0.10-0.k.6jpp.1
Oct 20 06:59:42 Installed: wsdl4j.x86_64 1.5.2-4jpp.1
Oct 20 06:59:43 Installed: axis.x86_64 1.2.1-2jpp.7.fc7
Oct 20 06:59:44 Installed: mx4j.x86_64 3.0.1-6jpp.4
Oct 20 06:59:45 Installed: jakarta-commons-modeler.x86_64 2.0-3jpp.1.fc7
Oct 20 06:59:47 Installed: tomcat5-server-lib.x86_64 5.5.23-9jpp.2.fc7
Oct 20 06:59:53 Installed: java-1.5.0-gcj-javadoc.x86_64 1.5.0.0-14.fc7
Oct 20 06:59:54 Installed: jdepend.x86_64 2.6-6jpp.1
Oct 20 06:59:55 Installed: ant-jdepend.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:56 Installed: jzlib.x86_64 1.0.7-4jpp.1
Oct 20 06:59:57 Installed: jsch.x86_64 0.1.28-1jpp.6
Oct 20 06:59:58 Installed: ant-jsch.x86_64 1.6.5-4jpp.2.fc7
Oct 20 06:59:58 Installed: jakarta-commons-daemon.x86_64 1.0.1-6jpp.2.fc7
Oct 20 07:00:00 Installed: tomcat5.x86_64 5.5.23-9jpp.2.fc7
Oct 20 07:00:09 Installed: eclipse-platform.x86_64 3.2.2-15.fc7
Oct 20 07:00:12 Installed: eclipse-cdt.x86_64 3.1.2-8.fc7
Oct 20 07:00:13 Installed: eclipse-changelog.x86_64 2.3.4-1.fc7
Oct 20 07:00:17 Installed: eclipse-jdt.x86_64 3.2.2-15.fc7
*"it's working!  it's working!" - a skywalker*

:-)
Comment 4 cje 2007-10-20 20:53:54 EDT
FYI, it's <strike>broken</strike>fixed again.  i'll reopen if i can't fix it or
when i can get enough details (and sleep). .. or if it stays broken.

since last time i've restored my old workspace folder, opened my projects,
edited, saved and built.  all okay.

now i try to start eclipse again (from normal panel menu) and it got stuck in
the splash screen again.  before it would get stuck before the progress bar has
turned grey and shown any progress or displayed progress text.  this time it got
quite a way through and then got stuck starting the debug something.  possibly
eclipse.debug.ui ?

i left it for  an hour or so.  when i came back the splash screen had gone but
/usr/share/eclipse/startup.jar was still going.  did a 'killall java' to get rid
of that.  that popped up the following error dialog:
JVM terminated. Exit code=1
/usr/bin/java
-Xms40m
-Xmx256m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata b08027
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx256m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar

which looks familiar.

trying again... works!  grrr.

Note You need to log in before you can comment on or make changes to this bug.