Bug 34128 - anaconda crashes when leaving account setup page during bootnet install via nfs
anaconda crashes when leaving account setup page during bootnet install via nfs
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 50408 50782 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-30 13:28 EST by bil kleb
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 15:27:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bil kleb 2001-03-30 13:28:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686)


Using the bootnet.img from the stock redhat-7.0 cdrom, I use the NFS image
install
option to install over the network via a copy of the cdrom files according
to the
README file, e.g., cp -a /mnt/cdrom/RedHat /mirror/RedHat-7.0, etc.

The installation proceeds normally until I enter the root password (and do
not
create any other user accounts) and hit "Next".  At that point anaconda
dies
and tells me to save the stuff to floppy and send a Buzilla report...

Reproducible: Always
Steps to Reproduce:
1. See above discription
	

Actual Results:  Anaconda traceback appears.

Expected Results:  Installation continues normally.

from anacdump.txt created on floppy:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 463, in
setScreen
    direction ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/package_gui.py", line
426, in getScreen
    self.todo.getHeaderList ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 532, in
getHeaderList
    self.hdList = self.method.readHeaders()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 22, in
readHeaders
    return HeaderListFromFile(self.tree + "/RedHat/base/hdlist")
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 136, in
__init__
    hdlist = rpm.readHeaderListFromFile(path)
rpm.error: (2, 'No such file or directory')

Local variables in innermost frame:
compatPackages: None
self: <comps.HeaderListFromFile instance at 84771f8>
path: /mnt/source/./RedHat/base/hdlist

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
NfsInstallMethod
p4
(dp5
S'tree'
p6
S'/mnt/source/.'
sbsS'initlevel'
p7
I3
sS'progressWindow'
p8
NsS'expert'
p9
I0
sS'ddruidReadOnly'
p10
I0
sS'bootdisk'
p11
I1
sS'language'
p12
(itodo
Language
(dp13
S'abbrevMap'
p14
(dp15
S'es_ES'
p16
S'Spanish'
p17
sS'tr_TR'
p18
S'Turkish'
p19
sS'sr_YU'
p20
S'Serbian'
p21
sS'de_DE'
p22
S'German'
p23
sS'sk_SK'
p24
S'Slovak'
p25
sS'ru_RU.KOI8-R'
p26
S'Russian'
p27
sS'is_IS'
p28
S'Icelandic'
p29
sS'no_NO'
p30
S'Norwegian'
p31
sS'sv_SE'
p32
S'Swedish'
p33
sS'en_US'
p34
S'English'
p35
sS'it_IT'
p36
S'Italian'
p37
sS'da_DK'
p38
S'Danish'
p39
sS'cs_CZ'
p40
S'Czech'
p41
sS'uk_UA.KOI8-U'
p42
S'Ukrainian'
p43
sS'hu_HU'
p44
S'Hungarian'
p45
sS'fr_FR'
p46
S'French'
p47
sS'sl_SI'
p48
S'Slovenian'
p49
sS'ro_RO'
p50
S'Romanian'
p51
ssS'font'
p52
(dp53
g37
S'lat0-sun16'
sg21
S'cyr-sun16'
sg27
S'cyr-sun16'
sg35
S'None'
sg25
S'lat2-sun16'
sg31
S'lat0-sun16'
sg33
S'lat0-sun16'
sg47
S'None'
sg49
S'lat2-sun16'
sg51
S'lat2-sun16'
sg23
S'None'
sg19
S'lat5-sun16'
sg45
S'lat2-sun16'
sg17
S'None'
sg43
S'cyr-sun16'
sg41
S'lat2-sun16'
sg39
S'lat0-sun16'
sg29
S'lat0-sun16'
ssS'langs'
p54
(dp55
g37
g36
sg21
g20
sg27
g26
sg35
g34
sg25
g24
sg31
g30
sg33
g32
sg47
g46
sg49
g48
sg51
g50
sg23
g22
sg19
g18
sg45
g44
sg17
g16
sg43
g42
sg41
g40
sg39
g38
sg29
g28
ssS'info'
p56
(dp57
S'LANG'
p58
g34
ssS'map'
p59
(dp60
g37
S'iso15'
sg21
S'iso05'
sg27
S'koi8-r'
sg35
S'None'
sg25
S'iso02'
sg31
S'iso15'
sg33
S'iso15'
sg47
S'None'
sg49
S'iso02'
sg51
S'iso02'
sg23
S'None'
sg19
S'iso09'
sg45
S'iso02'
sg17
S'None'
sg43
S'koi8-u'
sg41
S'iso02'
sg39
S'iso15'
sg29
S'iso15'
ssS'lang'
p61
g34
sbsS'fstab'
p62
NsS'lilo'
p63
(ililo
LiloConfiguration
(dp64
S'liloDevice'
p65
S'mbr'
p66
sS'initrdsMade'
p67
(dsS'edd'
p68
I0
sS'default'
p69
NsS'liloImages'
p70
(dsS'liloLinear'
p71
I1
sS'liloAppend'
p72
S''
sbsS'comps'
p73
NsS'network'
p74
(itodo
Network
(dp75
S'netdevices'
p76
(dp77
S'eth0'
p78
(itodo
NetworkDevice
(dp79
g56
(dp80
S'ONBOOT'
p81
S'yes'
sS'IPADDR'
p82
S'192.168.0.11'
sS'DEVICE'
p83
g78
sS'NETWORK'
S'192.168.0.0'
sS'BOOTPROTO'
p84
S'static'
sS'NETMASK'
p85
S'255.255.255.0'
sS'BROADCAST'
S'192.168.0.255'
ssbsS'eth1'
p86
(itodo
NetworkDevice
(dp87
g56
(dp88
S'ONBOOT'
S'yes'
p89
sg83
g86
ssbssS'gateway'
p90
S'192.168.0.1'
sS'secondaryNS'
p91
S'128.155.3.55'
sS'hostname'
p92
S'cn01'
sS'primaryNS'
p93
S'128.155.3.35'
sS'domains'
p94
(lsS'isConfigured'
p95
I1
sS'readData'
p96
I1
sS'ternaryNS'
p97
S'128.155.3.35'
sbsS'upgrade'
p98
I0
sS'instClass'
p99
(iworkstation
InstallClass
(dp100
S'rootPasswordCrypted'
p101
I0
sS'nameserver'
p102
S''
sS'x'
NsS'rootPassword'
p103
NsS'makeBootdisk'
p104
I1
sS'installType'
p105
NsS'postScript'
p106
NsS'earlySwapOn'
p107
I0
sS'networkDevice'
p108
NsS'clearText'
p109
Nsg63
(g66
I1
S''
tsg12
NsS'name'
p110
S''
sS'postInChroot'
p111
I0
sS'pixmap'
p112
S''
sS'partitions'
p113
(lp114
(S'/boot'
p115
(I16
I-1
I0
t(S''
I-1
I0
t(I0
I0
tNta(S'/'
(I700
I-1
I1
t(S''
I-1
I0
t(I0
I0
tNta(S'swap'
p116
(I64
I-1
I0
t(S''
I-1
I0
t(I0
I0
tNtasS'clearType'
p117
S'wkst'
p118
sg90
S''
sS'mouse'
p119
NsS'packages'
p120
NsS'timezone'
p121
NsS'zeroMbr'
p122
I0
sS'keyboard'
p123
NsS'groups'
p124
(lp125
S'Workstation Common'
p126
asS'bootProto'
p127
NsS'netmask'
p128
S''
sS'raidList'
p129
(lsS'skipSteps'
p130
(dp131
S'authentication'
p132
I1
sg63
I1
ssS'auth'
p133
(I1
I1
I0
S''
I0
S''
I0
I0
S''
S''
I0
S''
S''
S''
I0
S''
S''
tsg92
S'localhost.localdomain'
p134
sg62
(lsS'showgroups'
p135
(lp136
S'KDE'
p137
aS'GNOME'
p138
aS'Games'
p139
asS'ip'
p140
S''
sS'defaultRunlevel'
p141
NsS'desktop'
p142
S''
sS'clearPartText'
p143
S'You are about to erase any preexisting Linux installations on your
system.'
p144
sS'clearParts'
p145
I2
sbsS'rootpassword'
p146
NsS'extraModules'
p147
(lp148
sg119
(imouse
Mouse
p149
(dp150
S'device'
p151
S'psaux'
p152
sg56
(dp153
S'XMOUSETYPE'
p154
S'PS/2'
p155
sS'FULLNAME'
p156
S'Generic - 3 Button Mouse (PS/2)'
sS'MOUSETYPE'
p157
S'ps/2'
p158
ssS'emu'
p159
I0
sS'wasProbed'
p160
I1
sS'emulate'
p161
I0
sbsS'ddruidAlreadySaved'
p162
I0
sS'serial'
p163
I0
sg121
(S'America/New_York'
I0
I0
tsg122
I0
sg123
(ikbd
Keyboard
(dp164
S'layout'
p165
NsS'model'
p166
NsS'type'
p167
S'PC'
p168
sg56
(dp169
S'KEYBOARDTYPE'
p170
S'pc'
p171
sS'KEYTABLE'
p172
S'us'
p173
ssbsS'fdDevice'
p174
S'fd0'
p175
sS'installSystem'
p176
I1
sS'setupFilesystems'
p177
I1
sg133
(itodo
Authentication
(dp178
S'useNIS'
p179
I0
sS'nisServer'
p180
S''
sS'useLdap'
p181
I0
sS'krb5Kdc'
p182
S''
sS'useHesiod'
p183
I0
sS'ldapServer'
p184
S''
sS'nisDomain'
p185
S''
sS'krb5Realm'
p186
S''
sS'useLdapauth'
p187
I0
sS'hesiodRhs'
p188
S''
sS'useShadow'
p189
I1
sS'nisuseBroadcast'
p190
I0
sS'useKrb5'
p191
I0
sS'useMD5'
p192
I1
sS'ldapBasedn'
p193
S''
sS'krb5Admin'
p194
S''
sS'hesiodLhs'
p195
S''
sS'hesiodDlhs'
p196
S''
sbsg92
g134
sS'reconfigOnly'
p197
I0
sS'x'
(ixf86config
XF86Config
p198
(dp199
S'monlist'
p200
(dsS'keyModel'
p201
S'pc101'
p202
sS'monids'
p203
(dsg151
NsS'monEisa'
p204
NsS'server'
p205
S'XF86_Mach64'
sS'monHoriz'
p206
S'31.5'
p207
sS'devID'
p208
S'ATI Mach64'
p209
sS'descr'
p210
S'ATI|Rage XL'
p211
sS'modes'
p212
(dp213
S'8'
(lp214
S'640x480'
p215
assS'keyOptions'
p216
S''
sS'keyVariant'
p217
S''
sS'monID'
p218
S'Unprobed Monitor'
p219
sS'keyLayout'
p220
S'us'
p221
sS'manualModes'
p222
(dsg119
g149
sS'keyRules'
p223
S'xfree86'
p224
sS'monVert'
p225
S'60'
p226
sS'cardMan'
p227
S'ATI MACH64'
p228
sS'monSect'
p229
S''
sS'primary'
p230
I0
sS'vidRam'
p231
S'4096'
sS'probed'
p232
I1
sS'monName'
p233
NsS'vidCards'
p234
(lp235
(dp236
S'SERVER'
S'Mach64'
sS'UNSUPPORTED'
S''
sS'DRIVER'
S'ati'
sS'NOCLOCKPROBE'
S''
sS'NAME'
g209
sS'VENDOR'
p237
g228
sS'CHIPSET'
S'ATI-Mach64'
sasS'skip'
p238
I0
sS'files'
p239
S'\012# The location of the RGB database.  Note, this is the name of
the\012# file minus the extension (like ".txt" or ".db").  There is
normally\012# no need to change the default.\012\012   
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and
later now use a font server independent of\012# the X server to render
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012   
FontPath   "unix/:7100"\012'
p240
sbsS'users'
p241
NsS'instPath'
p242
S'/mnt/sysimage'
p243
sS'intf'
p244
NsS'hdList'
p245
Nsb.
Comment 1 bil kleb 2001-03-30 15:23:37 EST
my error, I did the copy from cdrom incorrectly on the second disk, making
a whole host of incorrect paths
Comment 2 Brent Fox 2001-08-06 11:31:48 EDT
*** Bug 50408 has been marked as a duplicate of this bug. ***
Comment 3 Brent Fox 2001-08-10 00:11:22 EDT
*** Bug 50782 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.