Bug 341561 - multiarch conflicts in ImageMagick
multiarch conflicts in ImageMagick
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:40 EDT by Bill Nottingham
Modified: 2014-03-16 23:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-27 10:31:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:40:49 EDT
ImageMagick (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/bin/Magick++-config from install of ImageMagick-c++-devel-6.3.5.9-1.fc8 conflicts with file from package ImageMagick-c++-devel-6.3.5.9-1.fc8
  file /usr/include/wand/wand-config.h from install of ImageMagick-devel-6.3.5.9-1.fc8 conflicts with file from package ImageMagick-devel-6.3.5.9-1.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Hans de Goede 2008-04-27 10:31:50 EDT
Short intro: I'm a new co-maintainer of ImageMagick and as such I'm going
through all open ImageMagick bugs.

6.4.0.10-1, fixes this and will show up in rawhide once rawhide unfreezes from
the current F-9 final freeze.
Comment 2 Ed Hill 2008-06-24 18:01:26 EDT
Is there any chance this fix will be applied to the ImageMagick-devel shipped 
in F8 and/or F9 ?  I'm just curious since I ran into this problem on a few F8 
x86_64 machines.

Thank you!
Comment 3 Hans de Goede 2008-06-25 04:19:49 EDT
The rawhide and F-9 versions are unfortunately not in sync due to an ABI change
in the latest F-9. Backporting the multilib fixes to F-9 is doable (and not very
hard). But will take some effort and I'm afraid I currently do not have the time
todo this. Therefor given the small impact of this issue (and only for
developers) currently there are no plans to backport this to F-9 or earlier.

Note You need to log in before you can comment on or make changes to this bug.