Bug 34175 - up2date dies if it does not find a file from server that it believed being there
up2date dies if it does not find a file from server that it believed being there
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Cristian Gafton
Jay Turner
:
: 33708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-30 17:16 EST by Toni Willberg
Modified: 2015-01-07 18:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 18:47:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2001-03-30 17:16:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1 i686)


up2date dies if it does not find a file from server that it believed being
there. Perhaps server lied to client. It's a bug. The client should not die
but ask user what to do.

Reproducible: Always
Steps to Reproduce:
1. up2date -u --nox


Actual Results:  [root@pentti updates]# up2date -u --nox

Retrieving list of all available packages...

Removing installed packages from list of updates...
###################################
Aborted.
[root@pentti updates]# up2date -v -u --nox

Retrieving list of all available packages...

Removing installed packages from list of updates...
########################################

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
/usr/src/updates/gcc-2.96-69.i386.rpm: gpg OK
/usr/src/updates/glibc-2.2-12.i386.rpm: gpg OK
/usr/src/updates/gcc-g77-2.96-69.i386.rpm: gpg OK
/usr/src/updates/glibc-devel-2.2-12.i386.rpm: gpg OK
/usr/src/updates/gcc-c++-2.96-69.i386.rpm: gpg OK
/usr/src/updates/gcc-objc-2.96-69.i386.rpm: gpg OK
There was a fatal error communicating with the server.  The message was:

ERROR: File not found
INFO : Unable to access RPM package: ['krb5-devel', '1.2.2', '3', '',
755013]

        An error has occured while processing your request. If this problem
        persists please submit a bug report to rhn-help@redhat.com.
        If you choose to submit the bug report, please be sure to include
        details of what were you trying to do when this error occured and
        details on how to reproduce this problem.
        
[root@pentti updates]#


Expected Results:  How about not crashing on every unpredicted event?

[root@pentti updates]# rpm -q up2date
up2date-2.4.4-1

[root@pentti updates]# rpm -q redhat-release
redhat-release-7.0-1

[root@pentti updates]# date
Sat Mar 31 01:13:48 EEST 2001
Comment 1 Preston Brown 2001-03-30 21:53:26 EST
That was a graceful exit under unknown circumstances, not a crash.  When in command line mode 
(batch mode) we don't want any interaction beyond command line options.

This was a server side problem that should be corrected by now.
Comment 2 Toni Willberg 2001-03-31 03:24:50 EST
Same "graceful exit" also happened when using GUI version.

As experienced user I'm used to this kind of "features" in Linux programs but
think about John Newbie who just installed his first RedHat Linux and wanted to
update it. J. Newbie might feel quite stupid when the up2date program
"gracefully exits".

I still consider this behaviour as a bug. No client should die in event of
predictable error event (imagine [your favourite www-browser] to die when 404
happens ;). In this case there should be a way to tell the up2date client to
skip "errorneus" or something packages.

That's all folks.
Comment 3 bil kleb 2001-04-10 21:20:22 EDT
Apparently the server is having problems again?  I am getting the same type of
error while running up2date in gnome:

...Getting headers for available packages...

then a dialog box comes up with something like:

 There was a fatal error communicating with the server.  The message was:
]  ERROR: File not found
   INFO: Unable to access RPM package: ['netscape-communicator','4.76','1','3']
Comment 4 Cristian Gafton 2001-04-11 18:47:32 EDT
*** Bug 33708 has been marked as a duplicate of this bug. ***
Comment 5 Cristian Gafton 2001-04-11 18:55:30 EDT
this was a temporary server side issue (the FTP server reorg) and has
not occured since.

Note You need to log in before you can comment on or make changes to this bug.