Bug 341951 - multiarch conflicts in libcaca
multiarch conflicts in libcaca
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libcaca (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
: 477289 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:44 EDT by Bill Nottingham
Modified: 2014-03-16 23:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 12:29:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:44:41 EDT
libcaca (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/bin/caca-config from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/caca_8h.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/cucul_8h.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/functions.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/functions_eval.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/functions_vars.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/globals.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/globals_eval.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/globals_type.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__attr__defines.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__attributes.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__caca.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__canvas.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__charset.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__cucul.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__dither.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__event.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__font.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__frame.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__importexport.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__prim.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/group__transform.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/migrating.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/news.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/structcaca__event.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/todo.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8
  file /usr/share/doc/libcaca-devel-0.99/html/tutorial.html from install of libcaca-devel-0.99-0.3.beta11.fc8 conflicts with file from package libcaca-devel-0.99-0.3.beta11.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Bug Zapper 2008-05-13 23:32:54 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matthias Saou 2008-12-21 08:17:53 EST
Changing to Rawhide, to not forget about this bug.
Comment 3 Matthias Saou 2008-12-21 08:18:23 EST
*** Bug 477289 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Saou 2008-12-21 12:29:41 EST
Should be fixed in devel now :
* Sun Dec 21 2008 Matthias Saou <http://freshrpms.net/> 0.99-0.6.beta16
- Add patch to share the same caca-config for 32 and 64bit (#341951).
- Don't include the pdf devel doc, only html (again, fixed multilib conflict).

Note You need to log in before you can comment on or make changes to this bug.