Bug 342071 - multiarch conflicts in libgalago
multiarch conflicts in libgalago
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgalago (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:45 EDT by Bill Nottingham
Modified: 2014-03-16 23:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.5.2-7.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 06:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:45:53 EDT
libgalago (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/share/gtk-doc/html/libgalago/GalagoAccount.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/GalagoContext.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/GalagoCore.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/GalagoImage.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/GalagoObject.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/GalagoPerson.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/GalagoPresence.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/GalagoService.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/GalagoStatus.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/libgalago-Assertion-Macros.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/libgalago-D-BUS-Utility-Functions.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/libgalago-GalagoKeyValue.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8
  file /usr/share/gtk-doc/html/libgalago/libgalago-GalagoValue.html from install of libgalago-devel-0.5.2-5.fc8 conflicts with file from package libgalago-devel-0.5.2-5.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Bastien Nocera 2008-04-02 06:27:02 EDT
The differences in the files are caused by the section IDs generated by gtk-doc.

diff -ur usr.i386/share/gtk-doc/html/libgalago/GalagoAccount.html
usr.x86_64/share/gtk-doc/html/libgalago/GalagoAccount.html
--- usr.i386/share/gtk-doc/html/libgalago/GalagoAccount.html    2008-04-02
11:01:19.000000000 +0100
+++ usr.x86_64/share/gtk-doc/html/libgalago/GalagoAccount.html  2008-04-02
11:01:07.000000000 +0100
@@ -22,22 +22,22 @@
 <th width="100%" align="center">libgalago Reference Manual</th>
 <td><a accesskey="n" href="GalagoContext.html"><img src="right.png" width="24"
height="24" border="0" alt="Next"></a></td>
 </tr>
-<tr><td colspan="5" class="shortcuts"><nobr><a href="#id2604597"
class="shortcut">Top</a>
+<tr><td colspan="5" class="shortcuts"><nobr><a href="#id4424380"
class="shortcut">Top</a>
                   &#160;|&#160;

Worked around in rawhide.

Note You need to log in before you can comment on or make changes to this bug.