Bug 342301 - multiarch conflicts in libopm
multiarch conflicts in libopm
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libopm (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
: Reopened
Depends On: 429425
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:48 EDT by Bill Nottingham
Modified: 2014-03-16 23:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.1-7.20050731cvs.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 22:38:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:48:03 EDT
libopm (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/share/doc/libopm-devel-0.1/html/annotated.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/classes.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/compat_8c.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/compat_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/config_8c.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/config_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/files.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/functions.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/functions_vars.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/globals.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/globals_defs.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/globals_func.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/globals_type.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/globals_vars.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/index.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/inet_8c.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/inet_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/libopm_8c.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/libopm_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/list_8c.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/list_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/malloc_8c.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/malloc_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/opm_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/opm__common_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/opm__error_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/opm__types_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/proxy_8c.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/proxy_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/setup_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/snprintf_8c.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/snprintf_8h.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct___o_p_m.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct___o_p_m___c_a_l_l_b_a_c_k.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct___o_p_m___c_o_n_f_i_g.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct___o_p_m___c_o_n_n_e_c_t_i_o_n.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct___o_p_m___p_r_o_t_o_c_o_l.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct___o_p_m___p_r_o_t_o_c_o_l___c_o_n_f_i_g.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct___o_p_m___r_e_m_o_t_e.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct___o_p_m___s_c_a_n.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct__libopm__list.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct__libopm__node.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct__opm__config__hash.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct__opm__inaddr.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/struct__opm__sockaddr.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8
  file /usr/share/doc/libopm-devel-0.1/html/test_8c.html from install of libopm-devel-0.1-5.20050731cvs.fc8 conflicts with file from package libopm-devel-0.1-5.20050731cvs.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Robert Scheck 2007-10-20 12:59:28 EDT
Bill, can you please provide some more information how to resolve this problem? 
The files are generated by doxygen, so they must not be identical on different 
archs.
Comment 2 Bill Nottingham 2007-10-22 16:09:25 EDT
First, remove the timestamps (I believe there are some recipes for this
on-list). Embedded links are trickier, and are still being discussed.
Comment 3 Robert Scheck 2007-12-14 17:17:59 EST
37438 (libopm): Build on target fedora-4-epel succeeded.
37437 (libopm): Build on target fedora-5-epel succeeded.

Package: libopm-0.1-6.20050731cvs.fc7 Tag: dist-fc7-updates-candidate Status:
complete
Package: libopm-0.1-6.20050731cvs.fc8 Tag: dist-f8-updates-candidate Status:
complete
Package: libopm-0.1-6.20050731cvs.fc9 Tag: dist-f9 Status: complete
Comment 4 Fedora Update System 2007-12-15 12:44:15 EST
libopm-0.1-6.20050731cvs.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-12-15 12:47:11 EST
libopm-0.1-6.20050731cvs.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Robert Scheck 2008-01-19 14:31:48 EST
Problem is only solved on Rawhide neither on Fedora 7 nor at Fedora 8.
Comment 7 Bug Zapper 2008-05-13 23:34:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Robert Scheck 2008-05-25 10:33:44 EDT
Package: libopm-0.1-7.20050731cvs.fc7 Tag: dist-fc7-updates-candidate Status: 
complete
Package: libopm-0.1-7.20050731cvs.fc8 Tag: dist-f8-updates-candidate Status: 
complete
Package: libopm-0.1-7.20050731cvs.fc9 Tag: dist-f9 Status: complete
Package: libopm-0.1-7.20050731cvs.fc10 Tag: dist-f10 Status: complete
Comment 9 Fedora Update System 2008-05-25 10:35:12 EDT
libopm-0.1-7.20050731cvs.fc7 has been submitted as an update for Fedora 7
Comment 10 Fedora Update System 2008-05-25 10:35:13 EDT
libopm-0.1-7.20050731cvs.fc8 has been submitted as an update for Fedora 8
Comment 11 Fedora Update System 2008-05-28 22:38:05 EDT
libopm-0.1-7.20050731cvs.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-05-28 22:44:17 EDT
libopm-0.1-7.20050731cvs.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.