Bug 34272 - problem with /proc dir
problem with /proc dir
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-01 01:46 EST by Knut J BJuland
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-01 12:46:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2001-04-01 01:46:06 EST
nvidia kernel driver has been unable to open an entry in /proc dir wiht
rawhide kernel. But it work with linux-2.4.2-ac20. I think this problem
lies in your kernel.
Comment 1 Arjan van de Ven 2001-04-01 11:53:42 EDT
The problem lies in the fact that the nvidia driver is not opensource and we are
not allowed
to modify it to fix bugs or make it work with our kernel.
Comment 2 Knut J BJuland 2001-04-01 12:02:34 EDT
what is diffret betwen your kernel and vanila linux 2.4.2-ac20 kernel?
Comment 3 Knut J BJuland 2001-04-01 12:06:09 EDT
It work with every vanila kernel I have used since linux 2.4.2 through linux
2.4.3. I think it is a redhat problem that is wihtin your kernel. I'll try alsa
to see if it is a problem with alsa to.
Comment 4 Arjan van de Ven 2001-04-01 12:08:40 EDT
What part of "the driver is not opensource, we are not allowed to fix it" should
I explain more?
Comment 5 Knut J BJuland 2001-04-01 12:45:58 EDT
I think it is a bug your kernel,alsa-driver-0.9.0beta3 where also unable to open
an entries in /proc, with snddevice script.  I think Nvidia should give Redhat
source code for theire driver.
Comment 6 Bill Nottingham 2001-04-01 23:23:49 EDT
They won't. Believe us.

I tried the nvidia driver with our kernel about a week and a half ago; it
worked OK.

Talk to NVidia. You're free to give them our source code. ;)
Comment 7 Arjan van de Ven 2001-04-08 09:19:41 EDT
We put a fix in for the ALSA driver. I don't know (and don't care) if it fixes
nvidia too.

Note You need to log in before you can comment on or make changes to this bug.