Bug 342921 - multiarch conflicts in popt
multiarch conflicts in popt
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: popt (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
: Reopened
: 427818 (view as bug list)
Depends On: 425803 429425 432683
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:54 EDT by Bill Nottingham
Modified: 2014-03-16 23:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.13-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 22:41:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:54:14 EDT
popt (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/share/doc/popt-devel-1.12/html/annotated.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/bug.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/deprecated.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/files.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/findme_8c-source.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/findme_8c.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/findme_8c__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/findme_8c__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/findme_8h-source.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/findme_8h.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/findme_8h__dep__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/findme_8h__dep__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/functions.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/functions_vars.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/globals.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/globals_defs.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/globals_enum.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/globals_eval.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/globals_func.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/globals_type.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/globals_vars.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/graph_legend.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/graph_legend.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/index.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/pages.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8c-source.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8c.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8c__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8c__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8h-source.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8h.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8h__dep__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8h__dep__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8h__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popt_8h__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptconfig_8c-source.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptconfig_8c.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptconfig_8c__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptconfig_8c__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popthelp_8c-source.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popthelp_8c.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popthelp_8c__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/popthelp_8c__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptint_8h-source.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptint_8h.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptint_8h__dep__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptint_8h__dep__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptparse_8c-source.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptparse_8c.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptparse_8c__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/poptparse_8c__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structcolumns__s.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structoptionStackEntry.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structoptionStackEntry__coll__graph.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structoptionStackEntry__coll__graph.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpbm__set.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpoptAlias.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpoptContext__s.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpoptContext__s__coll__graph.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpoptContext__s__coll__graph.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpoptDone__s.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpoptItem__s.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpoptItem__s__coll__graph.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpoptItem__s__coll__graph.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/structpoptOption.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/system_8h-source.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/system_8h.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/system_8h__dep__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/system_8h__dep__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/system_8h__incl.md5 from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/system_8h__incl.png from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8
  file /usr/share/doc/popt-devel-1.12/html/todo.html from install of popt-devel-1.12-3.fc8 conflicts with file from package popt-devel-1.12-3.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Robert Scheck 2007-10-20 12:58:35 EDT
Bill, can you please provide some more information how to resolve this problem? 
The files are generated by doxygen, so they must not be identical on different 
archs.
Comment 2 Panu Matilainen 2007-10-24 06:27:36 EDT
One possibility would be splitting the apidocs to a separate package to remove
the conflict entirely, the other option is to remove the timestamping from the
doxygen generated files.
Comment 3 Robert Scheck 2007-12-13 18:23:36 EST
Well...removing the timestamping from the doxygen generated files does not solve
the problem at all: There are still remaining the *.png files. And I can't see
how a package splitting should/could solve this. Ideas regarding the *.png files
and can you me please give a hint, how a separate package maybe solves this problem?
Comment 4 Robert Scheck 2007-12-13 18:26:53 EST
For example the file poptint_8h__dep__incl.png is different on i386 and on
x86_64, even diff/cmp shows this.
Comment 5 Panu Matilainen 2007-12-14 01:36:41 EST
Only packages containing libraries are copied into multiarch repositories, so
splitting out the api docs to separate package removes the issue. See for
example rpm on x86_64: only rpm-libs has i386 and x86_64 versions in the repo,
the rest are only for x86_64 -> no conflict.
Comment 6 Robert Scheck 2007-12-15 18:59:22 EST
Okay, multiarch/multilib conflicts are solved now:

[robert@tux ~]$ ./multilib-cmp.py \
                  popt-devel-1.13-1.fc9.i386.rpm \
                  popt-devel-1.13-1.fc9.x86_64.rpm
No conflicts
[robert@tux ~]$ 
Comment 7 Jim Radford 2007-12-18 13:07:56 EST
Why isn't this pushed to fc8?

I had only popt-devel.i386 on my x86_64 machine due to the conflict.  This
caused subtle build problems when building distcc (which uses and tries to
autodetect popt).
Comment 8 Robert Scheck 2007-12-18 13:37:34 EST
I won't build that package mentioned above neither for F8 nor for Rawhide until 
the bug mentioned in #425803 is solved - otherwise I could bet you are one of the 
first ones claiming about that.
Comment 9 Robert Scheck 2007-12-30 17:02:44 EST
Package: popt-1.13-1.fc8 Tag: dist-f8-updates-candidate Status: complete
Package: popt-1.13-1.fc9 Tag: dist-f9 Status: complete

An update for Fedora 8 is around the corner and already requested for testing 
repository. Please test it carefully and reopen the bug report, if it doesn't 
solve the problem for you. Please also add a comment at bodhi:

https://admin.fedoraproject.org/updates/F8/pending/popt-1.13-1.fc8
Comment 10 Fedora Update System 2008-01-02 20:39:44 EST
popt-1.13-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update popt'
Comment 11 Robert Scheck 2008-01-07 13:26:01 EST
*** Bug 427818 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2008-01-15 18:11:55 EST
popt-1.13-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Dwayne Fontenot 2008-01-17 18:49:56 EST
problems appear to persist:

Transaction Check Error:
  file /usr/share/doc/popt-devel-1.13/html/annotated.html from install of
popt-devel-1.13-1.fc8.i386 conflicts with file from package
popt-devel-1.13-1.fc8.x86_64
...
Comment 14 Robert Scheck 2008-01-18 20:26:08 EST
Well, it would be nice, if the package could be tested BEFORE it gets pushed
to stable - it was for weeks now in testing but nobody cared. Anyway, I'll have 
a look to the issue, looks like the python multilib/multiarch script to detect 
such conflicts is just crap :-(
Comment 15 Robert Scheck 2008-01-19 14:26:32 EST
Okay, I've to blame doxygen for this. On Rawhide everything is just perfect, 
while on Fedora 8 it isn't - and both branches have the same popt spec file.
I opened a bug report for doxygen to get a newer version in Fedora 8 soon.
Comment 16 Fedora Update System 2008-02-16 09:33:38 EST
popt-1.13-2.fc8 has been submitted as an update for Fedora 8
Comment 17 Robert Scheck 2008-02-16 09:35:47 EST
Jim and Dwayne: Please test popt-1.13-2.fc8 and add positive charma to it. I 
won't push the update myself into stable, it just has to reach enough positive 
charma this time to make it a stable update.
Comment 18 Benjamin Smedberg 2008-02-22 17:01:37 EST
I don't know where popt-1.12-2.fc8 is, but I tested installing multi-arch
popt-1.12-3.fc9 (+popt-devel) into my FC8 install and it installs correctly.
Whatever charma is, I'd like to bestow it on these packages ;-)
Comment 19 Jim Radford 2008-04-03 21:56:03 EDT
Tested popt-1.12-2.fc8 and it works for me.  Only popt-1.12-1.fc8 is available
in bodhi, and it doesn't work.
Comment 20 Robert Scheck 2008-04-04 03:29:55 EDT
The latest popt package for F8 being not in bodhi just in koji is buggy, don't
use it.
Comment 21 Bug Zapper 2008-05-13 23:37:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Robert Scheck 2008-05-25 12:14:03 EDT
Package: popt-1.13-4.fc8 Tag: dist-f8-updates-candidate Status: complete
Package: popt-1.13-4.fc9 Tag: dist-f9-updates-candidate Status: complete 
Package: popt-1.13-4.fc10 Tag: dist-f10 Status: complete
Comment 23 Fedora Update System 2008-05-25 12:17:08 EDT
popt-1.13-4.fc8 has been submitted as an update for Fedora 8
Comment 24 Fedora Update System 2008-05-25 12:17:15 EDT
popt-1.13-4.fc9 has been submitted as an update for Fedora 9
Comment 25 Robert Scheck 2008-05-25 12:26:18 EDT
Jim, Dwayne and Benjamin: Please test latest popt update as soon as it reaches 
the testing repository and rate it with corresponding charma.
Comment 26 Benjamin Smedberg 2008-06-09 09:28:20 EDT
I don't know what charma is, but updates-testing WFM, thanks.
Comment 27 Fedora Update System 2008-07-08 22:41:11 EDT
popt-1.13-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2008-07-08 22:44:17 EDT
popt-1.13-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.