Bug 34371 - scheduler parameter for least-connections populates incorrectly or is not a valid parameter.
scheduler parameter for least-connections populates incorrectly or is not a v...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: piranha (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brian Brock
http://ha.redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-02 15:19 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 12:42:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/lvs.cf file contents and /var/log/messages contents from restarting pulse daemon. (1.41 KB, text/plain)
2001-04-02 15:47 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-04-02 15:19:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (WinNT; U)


When using the piranha web interface to configure an LVS router pair, the least connections parameter is one of four choices for the 
scheduler variable. When setting the variable to least-connections and applying the changes using the accept button, it looks like the changes 
are acceptable. However, when trying to restart the pulse daemon, there is an error on line 21 of the lvs.cf file. This line contains the scheduler 
variable which is populated with a value of pcc. "pcc" is not one of the four acceptable values for this variable. Also, when trying to manually 
enter "lc" (configuration documentation valid value for least-connections), the pulse daemon still finds an error with the value of the scheduler 
variable.

Reproducible: Always
Steps to Reproduce:
1.Login using the piranha web interface.
2. Go to virtual servers link. 
3. Edit the virtual server by choosing least-connections for the scheduler value.
4. view the /etc/lvs.cf file on line 21.
5. Restart the pulse daemon. 
6. See output from the command line.
7. View /var/log/messages. Go to the area in the file where you restarted the pulse daemon. Check for errors.
	

Actual Results:  After using the piranha web interface to set the value of the scheduler to "least-connections" and accepting the changes, the 
/etc/lvs.cf file has a value of "pcc" for the scheduler.
When restarting the pulse daemon, an error comes up saying "error on line 21." This line contains the scheduler variable.

Expected Results:  The /etc/lvs.cf file should have a value of "lc" for the scheduler variable on line 21. And the pulse daemon should start 
properly without errors.
Comment 1 Need Real Name 2001-04-02 15:47:12 EDT
Created attachment 14463 [details]
/etc/lvs.cf file contents and /var/log/messages contents from restarting pulse daemon.
Comment 2 Phil Copeland 2001-04-03 12:42:35 EDT
*nod*
The original version of piranha went out with least connections defined as 'ppc'
rather than 'lc'
This was corrected in later releases. This escaped testing due to lack of
equipment at the time.

I appologise for any inconvience you've suffered.

ftp://ha.redhat.com/pub/ha/experimental/6.X/SRPMS
ftp://ha.redhat.com/pub/ha/experimental/6.X/SRPMS/piranha-0.4.17-7.src.rpm

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.