This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 343721 - Yum Crashes On Loading (component failed:pirut)
Yum Crashes On Loading (component failed:pirut)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-20 02:10 EDT by Shailen Sobhee
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 15:54:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Pirut Crash Dump (2.79 KB, application/octet-stream)
2007-10-20 02:10 EDT, Shailen Sobhee
no flags Details

  None (edit)
Description Shailen Sobhee 2007-10-20 02:10:25 EDT
Description of problem:
Yum won't load, although it asked for the root password.
When  tried using Yum Extender (ver 2.0.1), pirut produced a crash dump (see 
attached). My yum.conf and yum.repos.d folder are still intact.


Version-Release number of selected component (if applicable):


How reproducible:
Each time I launch pirunt /yum updater.

Steps to Reproduce:
1.Launch Yum updater or
2.Launch Yum Extender, just after downloading primary.sqlite.bz2
3.
  
Actual results:


Expected results:


Additional info: Please see crash dump attached.
Comment 1 Shailen Sobhee 2007-10-20 02:10:25 EDT
Created attachment 233311 [details]
Pirut Crash Dump
Comment 2 Jeremy Katz 2007-10-22 14:08:45 EDT
Does this happen every time?  Can you run 'yum clean all' as root and then see
if it continues to occur?
Comment 3 Shailen Sobhee 2007-10-22 15:34:37 EDT
Yeah, at the time I got this error,initially. yum won't load at all, even if do 
a 'yum clean all', reset my repos.d folder or verify that my yum.conf is ok.

However, installing yumex 2.0.2 solved the issue. I haven't seen the pirut bug 
popping again.

I also tried to disable SELinux. I dont't know how far this has helped yum to 
load properly. 

In any case, help on the fedora forums has been of good use, but I shall let 
you know any further occurrence of this bug.

You may wish to close this issue, unless you have received more complaints 
about it, or you really wish to bring changes to yum/yumex.

Regards,

Shailen.
Comment 4 Jeremy Katz 2007-10-22 15:54:32 EDT
Okay.  I've put some changes into the current pirut (currently in
-updates-testing, will be updated and be pushed to f7-updates soon)

Note You need to log in before you can comment on or make changes to this bug.