Bug 344001 - Upgrade F7 - reports existing system on swap
Upgrade F7 - reports existing system on swap
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-20 14:20 EDT by Meriel Gore
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 17:13:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
As requested copy of fstab from working Fedora 7 system (685 bytes, text/plain)
2007-10-23 11:29 EDT, Meriel Gore
no flags Details

  None (edit)
Description Meriel Gore 2007-10-20 14:20:55 EDT
Description of problem: existing F7 system on /dev/sda1, with swap on /dev/sdb1
When upgrading, installer reports existing system to upgrade is on
/dev/sdb1 ... upgraded aborted 


Version-Release number of selected component (if applicable):

F8 test3
How reproducible:  Three attempts give same result.


Steps to Reproduce:
1 upgrade an existing Fedora 7 system  with / on /dev/sda1 /home on /dev/sda2
swap on /dev/sdb1 and /opt on /dev/sdb2
 
  
Actual results:


Expected results:


Additional info: Motherboard Abit KT7ARAID .. Disks  not on the  Highpoint
 but the normal IDE0 and IDE1 channels
Comment 1 Chris Lumens 2007-10-22 13:53:26 EDT
What error message are you getting?  Also please attach /etc/fstab from your
running system to this bug report.
Comment 2 Meriel Gore 2007-10-23 11:29:55 EDT
Created attachment 235141 [details]
As  requested copy of fstab from working Fedora 7 system
Comment 3 Meriel Gore 2007-10-23 12:59:03 EDT
Please note I do not get an error message , but when trying an upgrade from a 
working Fedora 7 system. the installer reports that it has _only_ found a
working system on /dev/sdb1, which you can see from /etc/fstab is the swap
partition. Most confusing.

Comment 4 David Cantrell 2007-10-25 17:13:13 EDT
So I've just recreated your above scenario, going from an F-7 box with that
partitioning setup upgrading to F-8 and it finds the F-7 installation on
/dev/sda1.  Looks like it's either WORKSFORME or we managed to fix it.

I'll mark it as WORKSFORME since there may be some other oddities at work here.

Note You need to log in before you can comment on or make changes to this bug.