Bug 345051 - yum update lops
yum update lops
Status: CLOSED DUPLICATE of bug 402991
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 07:11 EDT by Nigel Horne
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 22:36:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2007-10-22 07:11:13 EDT
Description of problem:
yum update loops and downloads nothing

Version-Release number of selected component (if applicable):
yum-3.2.5-1.fc7

How reproducible:
"yum update" at the (root) shell prompt

Steps to Reproduce:
1. Start a root shell prompt
2. Type yum update
3.
  
Actual results:
http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/releases/7/Everything/i386/os/repodata/filelists.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
filelists.sqlite.bz2      100% |=========================| 6.4 MB    00:29     
filelists.sqlite.bz2      100% |=========================| 4.1 MB    00:21     
http://ftp.udl.es/pub/fedora/linux/updates/7/i386/repodata/filelists.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
filelists.sqlite.bz2      100% |=========================| 4.1 MB    00:18     
http://ultra.linux.cz/MIRRORS/fedora.redhat.com/linux/updates/7/i386/repodata/filelists.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
filelists.sqlite.bz2      100% |=========================| 4.1 MB    00:18     
ftp://ftp.pbone.net/pub/fedora/linux/updates/7/i386/repodata/filelists.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
filelists.sqlite.bz2      100% |=========================| 4.1 MB    00:19     
ftp://ftp.tudelft.nl/pub/Linux/download.fedora.redhat.com/linux/updates/7/i386/repodata/filelists.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
filelists.sqlite.bz2      100% |=========================| 4.1 MB    00:19     
http://ftp.cc.uoc.gr/pub/fedora/linux/updates/7/i386/repodata/filelists.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
filelists.sqlite.bz2      100% |=========================| 4.1 MB    00:18     
http://ftp.upjs.sk/pub/fedora/linux/updates/7/i386/repodata/filelists.sqlite.bz2:
[Errno -1] Metadata file does not match checksum

etc .etc


Expected results:
Should update the operating system

Additional info:

Flushing /var/cache/yum doesn't help.
Waiting a bit and trying again doesn't help.
Comment 1 Jeremy Katz 2007-10-22 13:57:08 EDT
This tends to be due to mirrors being out of sync.  James was looking into this some
Comment 2 Rehan Khan 2007-11-28 10:54:54 EST
I have this same problem. Yum cycles through *ALL* the mirrors on the returned 
mirrorlist (takes about 10-15mins and it's about 20-25 mirrors before yum says 
it has a problem). For me its the comps.xml for fedora 8 updates.

I switched from the mirrorlist to baseurl in the repo conf for fedora 8 updates 
and it seems to work again. I then switched back to the mirrorlist url and it 
seems to be working again. Probably because it already has the right file and 
doesn't try to get the 'bad' file again.

This has been going for about 1.5 days. I can't believe that every mirror is 
out of sync for this long. I have seen this a few times before but it 
eventually finds a mirror that has the correct file usually within about five 
mirrors.

Perhaps yum should fall back to the base url if a certain number of mirror 
failures occurs. Maybe pinging the mirror manager or whatever to say it is 
doing this and some process rebuilds the metadata and the mirrors sync this the 
next time they are scheduled to (even though the repository itself hasn't 
changed).
Comment 3 Seth Vidal 2007-11-28 11:02:30 EST
actually the comps problem was a corruption in that file.

See: https://bugzilla.redhat.com/show_bug.cgi?id=402991

for more info.

Comment 4 Seth Vidal 2007-12-06 22:36:04 EST

*** This bug has been marked as a duplicate of 402991 ***

Note You need to log in before you can comment on or make changes to this bug.