Bug 345271 - [RHEL 5.2] Xen 3.1.1: Give memory back to dom0 after failed autoballoon
[RHEL 5.2] Xen 3.1.1: Give memory back to dom0 after failed autoballoon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 10:33 EDT by Cole Robinson
Modified: 2014-02-02 17:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:10:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug fix (1.62 KB, patch)
2009-02-11 10:22 EST, Michal Novotny
no flags Details | Diff

  None (edit)
Description Cole Robinson 2007-10-22 10:33:44 EDT
Cset 15328 from xen-3.1-testing.hg returns memory to dom0 if an autoballoon
attempt fails. It is recommended for inclusion in RHEL 5.2
Comment 1 RHEL Product and Program Management 2007-10-22 10:35:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 RHEL Product and Program Management 2008-03-11 15:38:45 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 3 Michal Novotny 2009-02-11 10:22:37 EST
Created attachment 331572 [details]
Bug fix

Before ballooning memory and allocating new memory to a new domain it saves the current dom0 memory status and if autobaloon fails, it gives memory back to dom0 by restoring the memory size allocated to dom0.
It's backport of upstream at http://xenbits.xensource.com/xen-3.1-testing.hg?rev/73f18a202ea3 . Works fine for me, tested on RHEL x86_64.

Michal
Comment 4 Jiri Denemark 2009-02-23 06:10:16 EST
A test package which fixes this issue (and several others as well) has been
made available at:

http://people.redhat.com/jdenemar/xen/

Could the reporter try it out and report if it fixes the problem or not?

Thank you for your cooperation.
Comment 5 Jiri Denemark 2009-03-02 05:22:03 EST
Fix built into xen-3.0.3-81.el5
Comment 7 zhanghaiyan 2009-07-29 05:55:32 EDT
Could you please help give this bug test steps? Thanks.
(Because it is hard to make autoballoon fail)
Comment 11 Chris Lalancette 2009-07-29 10:23:57 EDT
(In reply to comment #7)
> Could you please help give this bug test steps? Thanks.
> (Because it is hard to make autoballoon fail)  

You should be able to make autoballoon fail pretty easily by changing the dom0-min-mem parameter in /etc/xen/xend-config.sxp.  So, assuming you have 4GB of memory, do something like:

(dom0-min-mem 2048)

And then try to start a 3GB guest; that should cause the auto-balloon to fail, and then you should be able to validate that this is fixed.

Chris Lalancette
Comment 13 zhanghaiyan 2009-07-29 23:17:13 EDT
Verified on xen-3.0.3-91.el5 PASS
Comment 15 errata-xmlrpc 2009-09-02 06:10:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1328.html

Note You need to log in before you can comment on or make changes to this bug.