Bug 34531 - SIGSEGV in usernet wtih clones in /etc/sysconfig/network-scripts
SIGSEGV in usernet wtih clones in /etc/sysconfig/network-scripts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-03 12:55 EDT by Ole Craig
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 12:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against rp3-1.1.8 (942 bytes, patch)
2001-04-03 12:57 EDT, Ole Craig
no flags Details | Diff

  None (edit)
Description Ole Craig 2001-04-03 12:55:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.olc-smp i686)


rp3 (up to at least 1.1.8-1) results in a GNOME crash panel (segmentation
fault) if 
usernet is run while multiple files in /etc/sysconfig/network-scripts have
the same DEVICE identifier. This is particularly suboptimal for e.g.
laptops (where one might want to allow the user to control multiple
interfaces) which may move between networks. It's still the eth0 device
being manipulated, it's just that e.g. on the home network it should be
getting a DHCP address from the cablemodem router, and on the work LAN it
should have its normal IP.

Reproducible: Always
Steps to Reproduce:
1. cd /etc/sysconfig/network-scripts
2. cp ifcfg-eth0 ifcfg-eth1
3. perl -p -i -e 's/IPADDR.*$/IPADDR=10.10.10.10/g'
4. echo "USERCTL=true" >> ifcfg-eth1
5. echo "USERCTL=true" >> ifcfg-eth0
6. /usr/bin/usernet
	

Actual Results:  Gnome crash panel

Expected Results:  usernet  should have popped up

bug appears to be in utils/interface.c -- g_list_remove_link is called
incorrectly. Patch follows.
Comment 1 Ole Craig 2001-04-03 12:57:52 EDT
Created attachment 14543 [details]
patch against rp3-1.1.8
Comment 2 Nalin Dahyabhai 2001-04-03 15:41:26 EDT
Thanks for the patch!  I ended up going for a different fix (modifying the
contents of that list while iterating through it was just too creepy).  The
fix is in CVS, and will pop up in Raw Hide as rp3-1.1.9-1.
Comment 3 Ole Craig 2001-04-05 16:12:52 EDT
Grrr. 

I seem to have found another SEGV. Unfortunately, my local rawhide mirror
doesn't have rp3-1.1.9 yet, so I can't verify that it's rp3 and not a result of
my quick fix. 

Where's the CVS for this package? Is it someplace I can do anon CVS and grab
what you've got now? (I took a quick buzz around the RH site, and
sources.redhat.com didn't seem to be what I was looking for...)
/OLC
Comment 4 Nalin Dahyabhai 2001-04-05 16:51:36 EDT
The rp3 source tree lives in GNOME CVS.  The CVSROOT for anonymous access is
":pserver:anonymous@cvs.gnome.org:/cvs/gnome", and the component is "rp3".
Comment 5 Ole Craig 2001-04-05 18:28:39 EDT
<sigh> yep, another segfault. (I dunno if this should get a separate bug for RH
purposes, or move to GNOME's bug system, but I'll list it here for now. )

Here's how to reproduce: 
Create clone interfaces as before.
Start usernet, click on the main interface (e.g. eth0).
another window should popup, giving a choice of configurations. Choose one,
click <yes>.
Boom- segfault.

/OLC
Comment 6 Ole Craig 2001-04-06 12:19:20 EDT
new info: in addition to the GNOME crashpanel, there's also a stderr message
that's changing occasionally, as I continue to run usernet and crash; first it
was:

Gtk-WARNING **: invalid cast from `(unknown)' to `GtkCList'

then,

Gtk-WARNING **: invalid class type `(unknown)'  in cast to `GtkCList'

then,

Gtk-WARNING **: invalid cast from `gchar' to `GtkCList'

then back to the first message.
Comment 7 Nalin Dahyabhai 2001-04-06 22:28:16 EDT
This should be fixed in 1.1.10 (now in CVS, coming soon to Raw Hide), and
another possible problem of the same type is fixed as well.  Please reopen this
bug ID if you find that this is not the case.
Comment 8 Ole Craig 2001-04-09 13:05:53 EDT
Looks like that does the trick, thanks.

Note You need to log in before you can comment on or make changes to this bug.