Bug 345321 - [RHEL 5.2] Xen 3.1.1: Fix sched params to stick on reboot and be accurate in xm list
[RHEL 5.2] Xen 3.1.1: Fix sched params to stick on reboot and be accurate in ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
: 233287 479709 (view as bug list)
Depends On:
Blocks: 492190
  Show dependency treegraph
 
Reported: 2007-10-22 10:49 EDT by Cole Robinson
Modified: 2014-02-02 17:36 EST (History)
5 users (show)

See Also:
Fixed In Version: xen-3.0.3-86.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:10:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Domain scheduler params with CAP support and stick on reboot (5.24 KB, patch)
2009-03-25 11:10 EDT, Michal Novotny
no flags Details | Diff
Domain scheduler params with CAP support and stick on reboot update (6.20 KB, patch)
2009-04-01 04:28 EDT, Michal Novotny
no flags Details | Diff
Reindented new version (6.50 KB, patch)
2009-04-27 08:59 EDT, Michal Novotny
no flags Details | Diff
New version with updated translation of float-int for migration (6.50 KB, patch)
2009-05-05 07:57 EDT, Michal Novotny
no flags Details | Diff

  None (edit)
Description Cole Robinson 2007-10-22 10:49:35 EDT
Cset 15107 in xen-3.1-testing.hg fixes 'xm sched-credit' to preserve the changed
values on a guest reboot, and to show these values correctly in xm list --long.
It is recommended for inclusion in RHEL 5.2.
Comment 1 RHEL Product and Program Management 2007-10-22 10:54:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Daniel Berrange 2007-10-22 11:48:34 EDT
RHEL-5  Xen python userspace is based on Xen 3.0.3. The patch from changeset
15107 will not apply to our codebase at all. The 3.0.3 XenD does not track the
credit schedular parameters at all - it merely provides an RPC API to set them
after a guest has started.  If we want the capability from this report in any
useful form we will need significant development work in XenD and XM and
probably libvirt too.
Comment 3 RHEL Product and Program Management 2008-03-11 15:38:41 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 4 Michal Novotny 2009-03-25 11:10:56 EDT
Created attachment 336658 [details]
Domain scheduler params with CAP support and stick on reboot

Hi,
I've created a patch that's basically a backport of upstream at http://xenbits.xensource.com/xen-3.1-testing.hg?rev/2b97066633e6 but there has to be some issues resolved because the coding's not the same. The support for CAP was unfinished there so I added it because C function in libxc was ready for it but no Python tools obviously used it. Now it shows cpu_cap in `xm list --long` as well as it's stick when rebooting the VM. Also when creating a new guest it checks whether the CAP value is within allowed range and returns error if it's not. Default value for cpu_cap is set to 100 and it was tested using this scenario (PVguest has only 1 vcpu):

1. `xm create PVguest cpu_cap=150 cpu_weight=512` returns error:
    Invalid CAP range, valid range is from 0 to 100 for specified number of vcpus
1. `xm create PVguest cpu_cap=95 cpu_weight=512`
2. `xm list PVguest --long | grep cpu_`
    (cpu_weight 512.0)
    (cpu_cap 150)
    (cpu_time 20.542607017)
3. `xm sched-credit -d RHEL53 -c 50 -w 128`
4. `xm list RHEL53 --long | grep cpu_`
    (cpu_weight 128)
    (cpu_cap 50)
    (cpu_time 20.586875547)
5. `xm reboot RHEL53`
6. `xm console RHEL53 and wait until restart is complete`
7. `xm list RHEL53 --long | grep cpu_`
    (cpu_weight 128.0)
    (cpu_cap 50)
    (cpu_time 1.088661715)

Default for cpu_cap is set to 100 and cpu_weight's default is preserved to 1.0.

Michal
Comment 5 Michal Novotny 2009-03-25 11:21:28 EDT
Oh, sorry, I mispelled it, PVguest and RHEL53 are the same, I have just tried to change the original name RHEL53 to PVguest to tell viewers that the guest is a PV machine. Anyway RHEL53 is the original name of PVguest here and both the machines are the same.
Comment 6 Michal Novotny 2009-04-01 04:28:37 EDT
Created attachment 337468 [details]
Domain scheduler params with CAP support and stick on reboot update

Domain scheduler params with CAP support and stick on reboot update
Comment 7 Michal Novotny 2009-04-14 13:22:09 EDT
*** Bug 233287 has been marked as a duplicate of this bug. ***
Comment 8 Michal Novotny 2009-04-27 08:59:15 EDT
Created attachment 341423 [details]
Reindented new version

This is the new version of my patch with right reindentation.
Michal
Comment 9 Michal Novotny 2009-05-05 07:57:17 EDT
Created attachment 342443 [details]
New version with updated translation of float-int for migration

This is a new version with updated translation of float to int cpu_cap value for migrating domains...
Comment 10 Jiri Denemark 2009-05-21 11:39:25 EDT
Fix built into xen-3.0.3-86.el5
Comment 12 Chris Ward 2009-07-03 13:58:34 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 15 errata-xmlrpc 2009-09-02 06:10:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1328.html
Comment 17 Daniel Veillard 2009-11-09 12:35:56 EST
*** Bug 479709 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.