This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 345831 - planner fails to start due to missing g_once_init_enter_impl symbol
planner fails to start due to missing g_once_init_enter_impl symbol
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: planner (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 15:37 EDT by Ian Romanick
Modified: 2009-12-09 01:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 05:31:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Romanick 2007-10-22 15:37:20 EDT
Description of problem:

Starting planner results in the following error message:

planner: symbol lookup error: planner: undefined symbol: g_once_init_enter_impl

Version-Release number of selected component (if applicable):

planner-0.14.2-9.fc8

How reproducible:

Every time.

Steps to Reproduce:
1. Start from base FC7.
2. Update planner via 'yum --enablerepo development planner'
3. Try to run planner.
  
Actual results:


Expected results:


Additional info:

I did try removing the development planner package and re-install, and I
received the same error message.  There seems to be a missing dependency or
something.  Not sure.  Reverting to current FC7 planner (planner-0.14.2-4.fc7)
works fine.
Comment 1 Caolan McNamara 2007-10-23 05:31:16 EDT
That's a glib symbol, I guess they added the symbol but didn't bump the SONAME,
autorequires picks up the need for glib but without a SONAME bump can't force a
version. 

It's hopeless to manually add a glib version requires to planner just to support
someone trying to suck it back down to FC-7, e.g. gedit and all of the rest of
the glib using stack are also not requiring a specific glib version so they'd
all have to be changed, for a dubious edge case situation.

Note You need to log in before you can comment on or make changes to this bug.