Bug 346011 - Amarok segfaults when parsing some WMA tags
Amarok segfaults when parsing some WMA tags
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 380471 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 16:52 EDT by Julian Sikorski
Modified: 2007-12-12 14:58 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.4.7-13.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 14:58:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 151733 None None None Never

  None (edit)
Description Julian Sikorski 2007-10-22 16:52:43 EDT
Description of problem:
As stated in summary, some WMA tags make amarok crash. I tested them under
Windows and encountered no problems at all.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1147185488 (LWP 4711)]
0x000000329843f092 in TagLib::String::String () from /usr/lib64/libtag.so.1
(gdb) bt
#0  0x000000329843f092 in TagLib::String::String () from /usr/lib64/libtag.so.1
#1  0x000000342b1137f1 in TagLib::WMA::Attribute::toString (
    this=<value optimized out>) at wmaattribute.cpp:128
#2  0x000000342b11279c in TagLib::WMA::Tag::album (this=0x12f3f60)
    at wmatag.cpp:65
#3  0x000000342af6150c in MetaBundle::readTags (this=0x44609830, 
    readStyle=<value optimized out>, images=0x0) at metabundle.cpp:516
#4  0x000000342af63247 in MetaBundle (this=0x44609830, url=@0x44609b70, 
    noCache=false, readStyle=TagLib::AudioProperties::Fast, images=0x0)
    at metabundle.cpp:234
#5  0x000000342ae6d0a7 in CollectionDB::bundlesByUrls (this=0x342b478240, 
    urls=@0x44609e70) at collectiondb.cpp:3550
#6  0x000000342b00ee00 in UrlLoader::doJob (this=0x12c61f0)
    at playlistloader.cpp:222
#7  0x000000342b083cd5 in ThreadManager::Thread::run (this=0xd082f0)
    at threadmanager.cpp:302
#8  0x0000003425efb915 in QThreadInstance::start ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#9  0x0000003287a06407 in start_thread () from /lib64/libpthread.so.0
#10 0x0000003286ed4b0d in clone () from /lib64/libc.so.6
(gdb)

Version-Release number of selected component (if applicable):
taglib-1.5-0.5.20070924svn.fc8.x86_64
amarok-1.4.7-7.fc8.x86_64

How reproducible:
always

Steps to Reproduce:
1. start amarok
2. add a problematic file to playlist
  
Actual results:
crash

Expected results:
no crash

Additional info:
If there are some weirdnesses in the tag, I believe program should handle this
more gracefully.
Comment 1 Julian Sikorski 2007-10-22 17:05:46 EDT
Hmm, looks like WMA tags handling has become very flaky in general. Maybe it's
caused by taglib update?
Comment 2 Julian Sikorski 2007-10-22 17:14:08 EDT
Yeah. Change affected wma file to any wma file. I just confirmed the issue with
the files that were working fine previously.
Comment 3 Julian Sikorski 2007-11-29 05:49:05 EST
This is fixed in amarok svn as of revision #742872. While you're at updating the
package, could you please add MP4/AAC tag support? This requires adding
libmp4v2-devel to BR and passing --with-mp4v2 to configure.
Comment 4 Rex Dieter 2007-11-29 15:32:41 EST
Gotcha.

* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.7-12
- --with-mp4v2 (rh#346011)
- fix asf/wma support (rh#346011,kde#151733)

Will post when some test builds are ready to try.
Comment 5 Julian Sikorski 2007-11-29 17:19:39 EST
WMA/ASF works. Why did you make mp4v2 disabled by default though?
Comment 6 Julian Sikorski 2007-11-29 17:27:58 EST
Anyway, if for some reason it is supposed to stay optional, the typo in %build
stage needs to be fixed (s/%{?_with_livm4v2}/%{?_with_mp4v2}/), I guess.
Comment 7 Rex Dieter 2007-11-29 17:41:20 EST
crap, typos suck.

In the meantime, we have:
http://koji.fedoraproject.org/koji/buildinfo?buildID=26125
Comment 8 Rex Dieter 2007-11-29 19:44:38 EST
*** Bug 380471 has been marked as a duplicate of this bug. ***
Comment 9 Julian Sikorski 2007-12-04 10:54:11 EST
amarok-1.4.7-13.fc8.x86_64 does indeed fix the MP4/AAC tag writing problem.
Please go ahead and push that build to the repositories.
Comment 10 Rex Dieter 2007-12-04 12:18:29 EST
Latest build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=26142

queue'd for updates-testing.
Comment 11 Steven Stern 2007-12-05 19:31:01 EST
Thank you!  The latest build on koji fixed the WMA problem.
Comment 12 Fedora Update System 2007-12-06 15:55:22 EST
amarok-1.4.7-13.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update amarok'
Comment 13 Fedora Update System 2007-12-12 14:58:12 EST
amarok-1.4.7-13.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.