Bug 346291 - compat pam package lacks dependency on compat bash
compat pam package lacks dependency on compat bash
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pam (Show other bugs)
5.0
ia64 Linux
low Severity high
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 02:49 EDT by Erik Forsberg
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 06:14:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Forsberg 2007-10-23 02:49:51 EDT
Trying to install the i386 version of the pam package (pam-0.99.6.2-3.14.el5) on
a RHEL5 machine running on an Itanium machine, I get the following error:

# rpm -hiv pam-0.99.6.2-3.14.el5.i386.rpm 
Preparing...                ########################################### [100%]
error: %pre(pam-0.99.6.2-3.14.el5.i386) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping pam-0.99.6.2-3.14.el5
[root@CENDIO_RH Server]# rpm -qp --scripts pam-0.99.6.2-3.14.el5.i386.rpm 

Turns out that this is because there were no 32-bit bash installed - /bin/sh is
used by the preinstall scriptlet.

Looks like a missing dependency.
Comment 1 Tomas Mraz 2007-10-23 06:14:04 EDT
I'm curious why compat bash interpreter is necessary. Also the package cannot
require 32bit bash because rpm doesn't support arch specific requires.

Note You need to log in before you can comment on or make changes to this bug.