Bug 34653 - Missing shhopt.h header file
Missing shhopt.h header file
Status: CLOSED DUPLICATE of bug 23579
Product: Red Hat Linux
Classification: Retired
Component: netpbm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 05:12 EDT by Plummer, Martyn
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-04 05:12:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Plummer, Martyn 2001-04-04 05:12:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.17-14 i686)


The header file shhopt.h is not installed as part of netpbm-devel.
This creates problems when building the e1071 package for the R language
(see http://www.R-project.org and also Red Hat Powertools CD). To be
precise, the build fails because it can't find the header.

The header file pbmplus.h includes shhopt.h and pbmplus.h in turn is
included from pbm.h. So this problem should occur at build time with just
about any program that tries to use the netpbm library.

Building netpbm from source, the header file shhopt.h is installed when you
type "make install.hdrs".  This step is not used in the SPEC file for
netpbm. Instead, a selection of header files is installed manually.

I suggest the header shhopt.h should be installed, unless it is provided by
another package, in which case that package should be a requirement for
netpbm-devel.

Reproducible: Always
Steps to Reproduce:
1. Install R-base from the Red Hat powertools CD. 
2. Download the source for the e1071 package
   ftp://cran.r-project.org/pub/R/contrib/main/e1071_1.1-0.tar.gz
3. Create a directory to hold the library
    mkdir ~/Rlibs
4.  Try to build the package
    R CMD INSTALL e1071_1.1-0.tar.gz -l ~/Rlibs

	


Actual Results:  Here is the tail end of the build log:

gcc -I/usr/lib/R/include -I. -I/usr/local/include -mieee-fp
-D__NO_MATH_INLINES
 -fPIC  -O2 -march=i386 -mcpu=i686 -c pnm.c -o pnm.o
In file included from /usr/include/pbm.h:7,
                 from /usr/include/pgm.h:7,
                 from /usr/include/ppm.h:7,
                 from /usr/include/pnm.h:7,
                 from pnm.c:19:
/usr/include/pbmplus.h:305:20: shhopt.h: No such file or directory
make: *** [pnm.o] Error 1
ERROR: Compilation failed for package `e1071'


Expected Results:  Tail end of a clean build (Red Hat 6.2)

gcc -I/usr/lib/R/include -I. -I/usr/local/include -mieee-fp
-D__NO_MATH_INLINES  -fPIC  -O2 -m486 -fno-strength-reduce -g -c pnm.c -o
pnm.o
gcc -I/usr/lib/R/include -I. -I/usr/local/include -mieee-fp
-D__NO_MATH_INLINES  -fPIC  -O2 -m486 -fno-strength-reduce -g -c scaclust.c
-o scaclust.o
c++ -I/usr/lib/R/include -I. -I/usr/local/include -mieee-fp  -fPIC  -g -O2
-c svm.cpp -o svm.o
c++ -shared  -o e1071.so Rsvm.o cmeanscl.o cshell.o pnm.o scaclust.o svm.o
-L/usr/local/lib -lpnm -lppm -lpgm -lpbm  
 R
 help
 >>> Building/Updating help pages for package `e1071'
     Formats: text html latex example 
 DONE (e1071)

DONE (INSTALL)
Comment 1 Phil Knirsch 2001-04-05 10:09:30 EDT

*** This bug has been marked as a duplicate of 23579 ***
Comment 2 Plummer, Martyn 2001-04-05 10:39:38 EDT
Hmmm. I see that people keep submitting this bug report and you keep marking it
as a duplicate of a resolved bug.  This is a monumental waste of everybody's
time.  I can only reiterate the comments of jbednar@cs.utexas.edu (#22720) that
you should release an official erratum for Red Hat 7.0.

Note You need to log in before you can comment on or make changes to this bug.