Bug 34732 - Rage 128-based "Xpert 2000" video card not supported
Rage 128-based "Xpert 2000" video card not supported
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 51230 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 10:40 EDT by Douglas Kilpatrick
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-14 03:06:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci -v (2.25 KB, text/plain)
2001-04-04 10:40 EDT, Douglas Kilpatrick
no flags Details
lspci -vn (1.81 KB, text/plain)
2001-04-04 10:41 EDT, Douglas Kilpatrick
no flags Details
output of "startx" (4.73 KB, text/plain)
2001-04-04 10:42 EDT, Douglas Kilpatrick
no flags Details

  None (edit)
Description Douglas Kilpatrick 2001-04-04 10:40:19 EDT
The video card identifies itsself as a "Rage 128 SM".  Xconfigurator
believes it to be supported by the ATI driver, but X fails to find a video
card.  I've attached(/will attach) lspci -v, lspci -vn, and startx output.
Comment 1 Douglas Kilpatrick 2001-04-04 10:40:50 EDT
Created attachment 14643 [details]
lspci -v
Comment 2 Douglas Kilpatrick 2001-04-04 10:41:30 EDT
Created attachment 14644 [details]
lspci -vn
Comment 3 Douglas Kilpatrick 2001-04-04 10:42:01 EDT
Created attachment 14645 [details]
output of "startx"
Comment 4 Mike A. Harris 2001-04-23 22:13:12 EDT
Your video card and ethernet card are both on IRQ 11, which is a conflict.
This may or may not have to do with the problem, however XFree86 4.0.2 is
no longer in rawhide, and hence unsupported.  Please upgrade to Red Hat Linux
7.1 (Seawolf).

If the Seawolf XFree86 doesn't work, please reopen the bug and change the
component from rawhide to seawolf.

Thanks.
Comment 5 Douglas Kilpatrick 2001-07-19 10:15:53 EDT
http://www.xfree86.org/pipermail/xpert/2001-May/008351.html

Co-worker currently using the card got it to work without attempting to resolve
any IRQ conflicts by setting the ChipID to 0x5046.  (For values of "work" that
mean "Basic 2D X came up.  Have not tried anything interresting")
Comment 6 Mike A. Harris 2001-07-19 20:53:07 EDT
I just looked deeper into the X source and this card is not supported
by XFree86 (not listed in PCI id tables).  Send your lspci output above to
xfree86@xfree86.org, as we do not support cards that XFree86 does not
support.  We would of course like to do so, but that requires an upstream
change.
Comment 7 Mike A. Harris 2001-07-23 05:02:18 EDT
The latest ATI code update has some support for previously unsupported
chips.  It is not known yet if it is full support, but I will try
integrating it for testing.
Comment 8 Mike A. Harris 2001-08-14 02:34:26 EDT
*** Bug 51230 has been marked as a duplicate of this bug. ***
Comment 9 Mike A. Harris 2001-08-14 03:06:34 EDT
The previously mentioned ATI update did not in fact support
this chip.  I have added at least preliminary support to this
driver for Rage 128 SM (Xpert 2000) as of the XFree86-4.1.0-0.9.13
release, however it is currently untested.

Please test this driver out once it appears in rawhide, and
if you have any problems, please report them in new bug
reports in bugzilla.

RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.